aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysolar')
-rw-r--r--dev-python/pysolar/Manifest2
-rw-r--r--dev-python/pysolar/pysolar-0.10.ebuild (renamed from dev-python/pysolar/pysolar-0.8.ebuild)10
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/pysolar/Manifest b/dev-python/pysolar/Manifest
index e8d002718..d353c6cbd 100644
--- a/dev-python/pysolar/Manifest
+++ b/dev-python/pysolar/Manifest
@@ -1 +1 @@
-DIST pysolar-0.8.tar.gz 1574747 BLAKE2B 7343cbed9c7e80deb1ee54406ceb96daebef76495d1595c44467aa5a025d161e730f3356a3c1b11ce27a1c96d1d47bd97a2f3e95b8864f6009b2fb3a14a1a722 SHA512 ca9d168c1fd5142998d07a18d3dde812ed38c667f1226fc62deb1fb148669039f6c5707bfed9aeea4bef8fbe962235495705e41043d7e381413caf55f9abba99
+DIST pysolar-0.10.tar.gz 1569021 BLAKE2B f1f30b32030e6dda00635257b6d2cbc5d75bf8122f27db2db6c0471339b73f4123627b116008c262a7547b5ca7a0664318ad90a92d6d4fc0b53d65de708cde29 SHA512 bccb41874bb6f344a64db694b8ed81137ddaa7c0df9b6011192c3ce3acb4b8f4d934e70000d91ced005936c5e1751043a80ad96b5d262ebf1d96ee061326e114
diff --git a/dev-python/pysolar/pysolar-0.8.ebuild b/dev-python/pysolar/pysolar-0.10.ebuild
index 88f0505ef..0e11e7967 100644
--- a/dev-python/pysolar/pysolar-0.8.ebuild
+++ b/dev-python/pysolar/pysolar-0.10.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
AUTHOR=pingswept
@@ -17,12 +18,17 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Still depends on nose
+RESTRICT="test"
+
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
"
+distutils_enable_tests pytest
+
python_prepare_all() {
sed \
-e "s:'testsolar', ::" \