aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-doctestplus')
-rw-r--r--dev-python/pytest-doctestplus/Manifest2
-rw-r--r--dev-python/pytest-doctestplus/metadata.xml3
-rw-r--r--dev-python/pytest-doctestplus/pytest-doctestplus-0.11.2.ebuild24
-rw-r--r--dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild41
4 files changed, 45 insertions, 25 deletions
diff --git a/dev-python/pytest-doctestplus/Manifest b/dev-python/pytest-doctestplus/Manifest
index 4a1e50d88..fa08cd21b 100644
--- a/dev-python/pytest-doctestplus/Manifest
+++ b/dev-python/pytest-doctestplus/Manifest
@@ -1 +1 @@
-DIST pytest-doctestplus-0.11.2.tar.gz 34943 BLAKE2B a45779ff3d65e1b920282f400d67b618f620a9a905da69edff96db799f30e1b93562e69bd567a49629194b962a080b1f675619b0c6995227a1391c3d0e74be20 SHA512 fed49a551be78f51db60161ccfa592e461719cca76e2a48e3267e8a22dbec60d02d8fbb757a88cb5cf4dc22143e27d3d20f25b51855be835254c72fd8260abbd
+DIST pytest-doctestplus-0.12.1.tar.gz 36434 BLAKE2B 95baa9f6185423fdd3e61ec0c269de54a4cf3298f2db90087b1413608663e4200e48158240cf565c8cc267244fbf8d60a0a5241b3b8f1fa8c1187e34824b17ae SHA512 46b999abd5632fa5c5743900b8b78ee7b6be742959daeb85296ebdf820d7533cff0a78d1c8aed7f5d5a15436998b2f7fe3e571133be14fce056276900493fef9
diff --git a/dev-python/pytest-doctestplus/metadata.xml b/dev-python/pytest-doctestplus/metadata.xml
index 4f4367037..33e3f0e33 100644
--- a/dev-python/pytest-doctestplus/metadata.xml
+++ b/dev-python/pytest-doctestplus/metadata.xml
@@ -5,4 +5,7 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-doctestplus</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pytest-doctestplus/pytest-doctestplus-0.11.2.ebuild b/dev-python/pytest-doctestplus/pytest-doctestplus-0.11.2.ebuild
deleted file mode 100644
index 17b19cbb0..000000000
--- a/dev-python/pytest-doctestplus/pytest-doctestplus-0.11.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pytest plugin with advanced doctest features"
-HOMEPAGE="https://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# TODO: fix this
-# AttributeError: type object 'reprec' has no attribute 'assertoutcome'
-RESTRICT="test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
diff --git a/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild b/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild
new file mode 100644
index 000000000..89f6c46eb
--- /dev/null
+++ b/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin with advanced doctest features"
+HOMEPAGE="https://astropy.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+# Skip the remote tests
+EPYTEST_DESELECT=(
+ tests/test_doctestplus.py::test_remote_data_url
+ tests/test_doctestplus.py::test_remote_data_float_cmp
+ tests/test_doctestplus.py::test_remote_data_ignore_whitespace
+ tests/test_doctestplus.py::test_remote_data_ellipsis
+ tests/test_doctestplus.py::test_remote_data_requires
+ tests/test_doctestplus.py::test_remote_data_ignore_warnings
+)
+
+distutils_enable_tests pytest