aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-doctestplus')
-rw-r--r--dev-python/pytest-doctestplus/Manifest1
-rw-r--r--dev-python/pytest-doctestplus/metadata.xml11
-rw-r--r--dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-doctestplus/Manifest b/dev-python/pytest-doctestplus/Manifest
new file mode 100644
index 000000000..fa08cd21b
--- /dev/null
+++ b/dev-python/pytest-doctestplus/Manifest
@@ -0,0 +1 @@
+DIST pytest-doctestplus-0.12.1.tar.gz 36434 BLAKE2B 95baa9f6185423fdd3e61ec0c269de54a4cf3298f2db90087b1413608663e4200e48158240cf565c8cc267244fbf8d60a0a5241b3b8f1fa8c1187e34824b17ae SHA512 46b999abd5632fa5c5743900b8b78ee7b6be742959daeb85296ebdf820d7533cff0a78d1c8aed7f5d5a15436998b2f7fe3e571133be14fce056276900493fef9
diff --git a/dev-python/pytest-doctestplus/metadata.xml b/dev-python/pytest-doctestplus/metadata.xml
new file mode 100644
index 000000000..33e3f0e33
--- /dev/null
+++ b/dev-python/pytest-doctestplus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-doctestplus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild b/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild
new file mode 100644
index 000000000..89f6c46eb
--- /dev/null
+++ b/dev-python/pytest-doctestplus/pytest-doctestplus-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin with advanced doctest features"
+HOMEPAGE="https://astropy.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+# Skip the remote tests
+EPYTEST_DESELECT=(
+ tests/test_doctestplus.py::test_remote_data_url
+ tests/test_doctestplus.py::test_remote_data_float_cmp
+ tests/test_doctestplus.py::test_remote_data_ignore_whitespace
+ tests/test_doctestplus.py::test_remote_data_ellipsis
+ tests/test_doctestplus.py::test_remote_data_requires
+ tests/test_doctestplus.py::test_remote_data_ignore_warnings
+)
+
+distutils_enable_tests pytest