aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-igraph/python-igraph-0.9.11.ebuild')
-rw-r--r--dev-python/python-igraph/python-igraph-0.9.11.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/python-igraph/python-igraph-0.9.11.ebuild b/dev-python/python-igraph/python-igraph-0.9.11.ebuild
deleted file mode 100644
index 4d2a6ee5f..000000000
--- a/dev-python/python-igraph/python-igraph-0.9.11.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_PN="${PN#python-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python interface for igraph"
-HOMEPAGE="https://igraph.org"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-libs/igraph-0.9.0
- >=dev-python/texttable-1.6.2[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? (
- dev-python/cairocffi[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/plotly[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # fix the igraph include path
- cd src || die
- find -type f -name "*.h" -exec sed -i -e 's@#include <igraph@#include <igraph/igraph@g' {} + || die
- find -type f -name "*.c" -exec sed -i -e 's@#include <igraph@#include <igraph/igraph@g' {} + || die
- cd .. || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile --use-pkg-config
-}