aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzo/pyzo-4.11.2.ebuild')
-rw-r--r--dev-python/pyzo/pyzo-4.11.2.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pyzo/pyzo-4.11.2.ebuild b/dev-python/pyzo/pyzo-4.11.2.ebuild
deleted file mode 100644
index 772793be5..000000000
--- a/dev-python/pyzo/pyzo-4.11.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1 virtualx desktop xdg
-
-DESCRIPTION="The Python IDE for scientific computing"
-HOMEPAGE="https://pyzo.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# For some reason this requires network access
-# Qt: Session management error: Could not open network socket
-RESTRICT="test"
-
-RDEPEND="
- dev-python/QtPy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/visvis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc
-
-python_prepare_all() {
- # Use relative path to avoid access violation
- # Do not install the license file, install other data_files manually
- sed -i \
- -e 's:/usr/share/metainfo:share/metainfo:g' \
- -e '/LICENSE.md/d' \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_install() {
- distutils-r1_python_install
- python_doscript pyzolauncher.py
-}
-
-python_install_all() {
- insinto /usr/share/metainfo/
- doins pyzo.appdata.xml
-
- for size in 16 32 48 64 128; do
- newicon -s ${size} "${PN}/resources/appicons/pyzologo${size}.png" pyzologo.png
- done
- domenu "${PN}/resources/${PN}.desktop"
-
- distutils-r1_python_install_all
-}