aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtconsole/qtconsole-4.0.1-r1.ebuild')
-rw-r--r--dev-python/qtconsole/qtconsole-4.0.1-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/qtconsole/qtconsole-4.0.1-r1.ebuild b/dev-python/qtconsole/qtconsole-4.0.1-r1.ebuild
deleted file mode 100644
index 35469c150..000000000
--- a/dev-python/qtconsole/qtconsole-4.0.1-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="http://jupyter.org"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
- )
- || (
- dev-python/pyside[${PYTHON_USEDEP},svg]
- dev-python/PyQt4[${PYTHON_USEDEP},svg]
- dev-python/PyQt5[${PYTHON_USEDEP},svg]
- )
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13[${PYTHON_USEDEP}]
- "
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests --with-coverage --cover-package qtconsole qtconsole || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}