aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ripser/ripser-0.6.4.ebuild')
-rw-r--r--dev-python/ripser/ripser-0.6.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ripser/ripser-0.6.4.ebuild b/dev-python/ripser/ripser-0.6.4.ebuild
new file mode 100644
index 000000000..21d6b6ccd
--- /dev/null
+++ b/dev-python/ripser/ripser-0.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="python frontend for the fast ripser tda tool"
+HOMEPAGE="https://ripser.scikit-tda.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/persim[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hopcroftkarp[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest