aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/schema/schema-0.7.4.ebuild')
-rw-r--r--dev-python/schema/schema-0.7.4.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/schema/schema-0.7.4.ebuild b/dev-python/schema/schema-0.7.4.ebuild
deleted file mode 100644
index 05e8712bb..000000000
--- a/dev-python/schema/schema-0.7.4.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Schema validation just got Pythonic"
-HOMEPAGE="https://pypi.org/project/schema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Prevent schema from unconditionally requiring the last-rited contextlib2,
- # which schema actually conditionally requires only under EOL Python 2.x.
- sed -i -e '/\binstall_requires=/d' setup.py || die
-}