aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smart-open/smart-open-6.3.0.ebuild')
-rw-r--r--dev-python/smart-open/smart-open-6.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/smart-open/smart-open-6.3.0.ebuild b/dev-python/smart-open/smart-open-6.3.0.ebuild
new file mode 100644
index 000000000..b585f1d4b
--- /dev/null
+++ b/dev-python/smart-open/smart-open-6.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utils for streaming large files (S3, HDFS, gzip, bz2...) "
+HOMEPAGE="https://github.com/RaRe-Technologies/smart_open"
+SRC_URI="https://github.com/RaRe-Technologies/smart_open/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN//-/_}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/google-cloud-storage[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest