aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakemake')
-rw-r--r--dev-python/snakemake/Manifest2
-rw-r--r--dev-python/snakemake/metadata.xml6
-rw-r--r--dev-python/snakemake/snakemake-5.32.2.ebuild56
-rw-r--r--dev-python/snakemake/snakemake-7.32.4.ebuild67
4 files changed, 71 insertions, 60 deletions
diff --git a/dev-python/snakemake/Manifest b/dev-python/snakemake/Manifest
index d82883f77..eca03bc0e 100644
--- a/dev-python/snakemake/Manifest
+++ b/dev-python/snakemake/Manifest
@@ -1 +1 @@
-DIST snakemake-5.32.2.tar.gz 7010842 BLAKE2B 70526d55ae058d4658c9486cad993fd626308c2ae21cc8e4a484c4f0916d5835ab27b6205e500b13303cae13f659bd542442b1e9a255b7f7f4b7cb4878694a17 SHA512 aa9c53f451bcf454209df25c5bbc795c4d67f27d1b3fe641ce9b788ee1350826e0a4d92514a50fbce58e5a3a462cca9c4015a58646a36a6a3f043381cc5b929d
+DIST snakemake-7.32.4.gh.tar.gz 8885863 BLAKE2B 6bb7ff4722dd06f0edf5e8079b42f5e54d6f55f41e2987b7dae7f9b75df0d4d836138e28340e5977107a5cc0b5afe793b0d7897c501246cc1b4340eb4eca2f17 SHA512 34fef61528b18facab798652c88ed5c698ef02161e023255fdd024b7c7781c4e582cdb04b2740fdff9b6f3600acaec719742984acee57920bb48ef3b5af99d9a
diff --git a/dev-python/snakemake/metadata.xml b/dev-python/snakemake/metadata.xml
index cff648bf6..74c76cce1 100644
--- a/dev-python/snakemake/metadata.xml
+++ b/dev-python/snakemake/metadata.xml
@@ -6,11 +6,11 @@
<name>Michael Schubert</name>
</maintainer>
<maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
</maintainer>
<upstream>
- <remote-id type="bitbucket">johanneskoester/snakemake</remote-id>
<remote-id type="pypi">snakemake</remote-id>
+ <remote-id type="github">snakemake/snakemake</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/snakemake/snakemake-5.32.2.ebuild b/dev-python/snakemake/snakemake-5.32.2.ebuild
deleted file mode 100644
index 312699378..000000000
--- a/dev-python/snakemake/snakemake-5.32.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Make-like task language"
-HOMEPAGE="https://snakemake.readthedocs.io"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# missing test dep google.cloud
-RESTRICT="test"
-
-BDEPEND="test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/google-api-python-client[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- net-libs/google-cloud-cpp
-)"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/configargparse[${PYTHON_USEDEP}]
- dev-python/datrie[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/ratelimit[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/toposort[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- sci-mathematics/pulp[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinxcontrib-napoleon \
- dev-python/sphinx-argparse \
- dev-python/sphinx_rtd_theme \
- dev-python/docutils \
- dev-python/recommonmark
-distutils_enable_tests pytest
diff --git a/dev-python/snakemake/snakemake-7.32.4.ebuild b/dev-python/snakemake/snakemake-7.32.4.ebuild
new file mode 100644
index 000000000..711aac286
--- /dev/null
+++ b/dev-python/snakemake/snakemake-7.32.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Make-like task language"
+HOMEPAGE="https://snakemake.readthedocs.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# cannot import name '_helpers' from 'google.cloud'
+RESTRICT="test"
+
+BDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/google-api-python-client[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ net-libs/google-cloud-cpp
+ )
+"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/connection_pool[${PYTHON_USEDEP}]
+ dev-python/datrie[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/humanfriendly[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/reretry[${PYTHON_USEDEP}]
+ dev-python/smart-open[${PYTHON_USEDEP}]
+ dev-python/stopit[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ dev-python/throttler[${PYTHON_USEDEP}]
+ dev-python/toposort[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yte[${PYTHON_USEDEP}]
+ sci-mathematics/pulp[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-napoleon \
+ dev-python/sphinx-argparse \
+ dev-python/sphinx-rtd-theme \
+ dev-python/docutils \
+ dev-python/recommonmark \
+ dev-python/myst-parser
+distutils_enable_tests pytest