aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snuggs')
-rw-r--r--dev-python/snuggs/Manifest1
-rw-r--r--dev-python/snuggs/metadata.xml17
-rw-r--r--dev-python/snuggs/snuggs-1.4.7.ebuild26
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/snuggs/Manifest b/dev-python/snuggs/Manifest
new file mode 100644
index 000000000..d9ccc74fd
--- /dev/null
+++ b/dev-python/snuggs/Manifest
@@ -0,0 +1 @@
+DIST snuggs-1.4.7.tar.gz 7762 BLAKE2B fae10c4e6f759219cbecdbea4b8f49001980824fe1d43fba9d5b62837a88183d1ecb6f55e191b637048e03856b1c6466cb17a9c38dfa332537d8968c8510fc25 SHA512 c1f40e521d1b0cf15075b22b04000c74ecbd0522cdd820b8c159aac812924d877349b3f3bca93b09eed5b025a34c26665a41c7a52a8145419558b115cf8ef361
diff --git a/dev-python/snuggs/metadata.xml b/dev-python/snuggs/metadata.xml
new file mode 100644
index 000000000..19390156e
--- /dev/null
+++ b/dev-python/snuggs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Snuggs library parses S-expressions using numpy. Available function
+ include arithmetic and logical operators. Also members of the numpy
+ module such as "asarray()", "mean()" and "where" are available.
+</longdescription>
+ <upstream>
+ <remote-id type="github">mapbox/snuggs</remote-id>
+ <remote-id type="pypi">snuggs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/snuggs/snuggs-1.4.7.ebuild b/dev-python/snuggs/snuggs-1.4.7.ebuild
new file mode 100644
index 000000000..be3395de7
--- /dev/null
+++ b/dev-python/snuggs/snuggs-1.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1
+
+DESCRIPTION="S-expressions for numpy"
+HOMEPAGE="https://github.com/mapbox/snuggs"
+SRC_URI="https://github.com/mapbox/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest