aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-astropy')
-rw-r--r--dev-python/sphinx-astropy/Manifest2
-rw-r--r--dev-python/sphinx-astropy/metadata.xml3
-rw-r--r--dev-python/sphinx-astropy/sphinx-astropy-1.8.0.ebuild (renamed from dev-python/sphinx-astropy/sphinx-astropy-1.3.ebuild)16
3 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/sphinx-astropy/Manifest b/dev-python/sphinx-astropy/Manifest
index fc19e0aa8..7cbf6d7c8 100644
--- a/dev-python/sphinx-astropy/Manifest
+++ b/dev-python/sphinx-astropy/Manifest
@@ -1 +1 @@
-DIST sphinx-astropy-1.3.tar.gz 15797 BLAKE2B 737d7a4ae2f7ec6fb382cc8d6fa3de911d13000045e9691f21360b3938e4bebb9b4b70a804deb8bd4343f1bba8e297d8f39fd8ed7787946ba0cb859a4208c980 SHA512 c39df1df90d82e8f67546623fe334ca7d706020f1e00923fcfc41232289aff41d1e697f99ee9b6d43f35f31ef9566be4d9aa99404ee35e1ea85da4b8e30f2ae6
+DIST sphinx-astropy-1.8.0.tar.gz 18310 BLAKE2B 0d13ba59b2ffcb792e66e58d2a87057b79da811d38e6fd101b074b0edbf5ad6d76e79300f5863521b0bbb1b40921ba6773f8d37c32d68dd36078cb2d0497e2ff SHA512 f02fe8d3ed58ffeff190492c07e2df91a2bd5bcc8e82c6685002e543585a5fc1294ebd46821b7dc0a364540f3a45adacf1b90261b7da95657bc99dcd6130f4d5
diff --git a/dev-python/sphinx-astropy/metadata.xml b/dev-python/sphinx-astropy/metadata.xml
index 4f4367037..8d01c3b18 100644
--- a/dev-python/sphinx-astropy/metadata.xml
+++ b/dev-python/sphinx-astropy/metadata.xml
@@ -5,4 +5,7 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinx-astropy</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/sphinx-astropy/sphinx-astropy-1.3.ebuild b/dev-python/sphinx-astropy/sphinx-astropy-1.8.0.ebuild
index 4fc2ef799..89d58fc6b 100644
--- a/dev-python/sphinx-astropy/sphinx-astropy-1.3.ebuild
+++ b/dev-python/sphinx-astropy/sphinx-astropy-1.8.0.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Sphinx extensions and configuration specific to the Astropy project"
-HOMEPAGE="https://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.astropy.org/"
LICENSE="BSD"
SLOT="0"
@@ -19,9 +20,10 @@ KEYWORDS="~amd64 ~x86"
RESTRICT="test"
RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
dev-python/astropy-sphinx-theme[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]
dev-python/sphinx-automodapi[${PYTHON_USEDEP}]
dev-python/sphinx-gallery[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]