aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-automodapi')
-rw-r--r--dev-python/sphinx-automodapi/Manifest2
-rw-r--r--dev-python/sphinx-automodapi/metadata.xml3
-rw-r--r--dev-python/sphinx-automodapi/sphinx-automodapi-0.14.1-r1.ebuild (renamed from dev-python/sphinx-automodapi/sphinx-automodapi-0.13.ebuild)15
3 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/sphinx-automodapi/Manifest b/dev-python/sphinx-automodapi/Manifest
index 8856f8a59..31e6f3c8b 100644
--- a/dev-python/sphinx-automodapi/Manifest
+++ b/dev-python/sphinx-automodapi/Manifest
@@ -1 +1 @@
-DIST sphinx-automodapi-0.13.tar.gz 38240 BLAKE2B 51eaaebab92881563e0e9df03e2979dbf0d22bf61bd8a7c56198cfbbcf97a17447019296dcee25f3a5dce091efb0c8e0748fb83dd47e93976aa1b01e165cbce7 SHA512 394b45ddeb923248250989271e400586188df973c8b13d551345cd056322de1208a8d7a135c095b2daa7b5b491b77a4077bba2dc450ef718ea5dbe07f7f63d36
+DIST sphinx-automodapi-0.14.1.tar.gz 45504 BLAKE2B 1d6aa247c9991260c0d6421dbeb80adccec72f60e6e0035ef892d6582e62608dd526a77da6c4b5066c9c100228fd6aceb77a9965eab76c0b9117a96d76ee221a SHA512 fae2927f8f9ec29f5e8e945b2902a0fa94231446b514be884ddab1a8644b4e305408e986b74a4506447baf00c4941cf9e7585f0c8e82820935a3d831bcfa6374
diff --git a/dev-python/sphinx-automodapi/metadata.xml b/dev-python/sphinx-automodapi/metadata.xml
index 4f4367037..092a8c5e9 100644
--- a/dev-python/sphinx-automodapi/metadata.xml
+++ b/dev-python/sphinx-automodapi/metadata.xml
@@ -5,4 +5,7 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinx-automodapi</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/sphinx-automodapi/sphinx-automodapi-0.13.ebuild b/dev-python/sphinx-automodapi/sphinx-automodapi-0.14.1-r1.ebuild
index 5c93e04fe..e64b9a0e0 100644
--- a/dev-python/sphinx-automodapi/sphinx-automodapi-0.13.ebuild
+++ b/dev-python/sphinx-automodapi/sphinx-automodapi-0.14.1-r1.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Sphinx extension for auto-generating API documentation for entire modules"
-HOMEPAGE="https://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.astropy.org/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# TODO: fix this
+# Requires network for some reason
RESTRICT="test"
RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"