aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/throttler/throttler-1.2.2.ebuild')
-rw-r--r--dev-python/throttler/throttler-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/throttler/throttler-1.2.2.ebuild b/dev-python/throttler/throttler-1.2.2.ebuild
new file mode 100644
index 000000000..0d0d62a16
--- /dev/null
+++ b/dev-python/throttler/throttler-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Easy throttling with asyncio support"
+HOMEPAGE="https://github.com/uburuntu/throttler"
+SRC_URI="https://github.com/uburuntu/throttler/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest