aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/throttler')
-rw-r--r--dev-python/throttler/Manifest1
-rw-r--r--dev-python/throttler/metadata.xml12
-rw-r--r--dev-python/throttler/throttler-1.2.2.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/throttler/Manifest b/dev-python/throttler/Manifest
new file mode 100644
index 000000000..fcd07b799
--- /dev/null
+++ b/dev-python/throttler/Manifest
@@ -0,0 +1 @@
+DIST throttler-1.2.2.gh.tar.gz 8874 BLAKE2B f4f62059483551d2516e0d744ce4de4de1d83c5d169583944f2fba390acc2f6aadd5f212158de2c59b85356d71396a02404051e9206dfffec25be95ae983686a SHA512 a45cba0400e2e6225bcc396d1a216e781be9264345c215aa0c9e009d463bb80fca449ef0cc6a67657c443f9624e0864644cd5187351e815292894176dd6f13bb
diff --git a/dev-python/throttler/metadata.xml b/dev-python/throttler/metadata.xml
new file mode 100644
index 000000000..dff8139fd
--- /dev/null
+++ b/dev-python/throttler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">uburuntu/throttler</remote-id>
+ <remote-id type="pypi">throttler</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/throttler/throttler-1.2.2.ebuild b/dev-python/throttler/throttler-1.2.2.ebuild
new file mode 100644
index 000000000..0d0d62a16
--- /dev/null
+++ b/dev-python/throttler/throttler-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Easy throttling with asyncio support"
+HOMEPAGE="https://github.com/uburuntu/throttler"
+SRC_URI="https://github.com/uburuntu/throttler/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest