aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/visvis/visvis-1.14.0.ebuild')
-rw-r--r--dev-python/visvis/visvis-1.14.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/visvis/visvis-1.14.0.ebuild b/dev-python/visvis/visvis-1.14.0.ebuild
new file mode 100644
index 000000000..1f210c0b4
--- /dev/null
+++ b/dev-python/visvis/visvis-1.14.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An object oriented approach to visualization of 1D to 4D data"
+HOMEPAGE="https://github.com/almarklein/visvis"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest