aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wraps/wraps-0.2.0.ebuild')
-rw-r--r--dev-python/wraps/wraps-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wraps/wraps-0.2.0.ebuild b/dev-python/wraps/wraps-0.2.0.ebuild
new file mode 100644
index 000000000..b06b511cd
--- /dev/null
+++ b/dev-python/wraps/wraps-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION=" Meaningful and safe wrapping types. "
+HOMEPAGE="https://github.com/nekitdev/wraps"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+# package does not have test suite (yet)
+
+RDEPEND="
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.0-poetry_groups.patch"
+)
+
+distutils_enable_tests pytest