aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xgboost/xgboost-1.6.2.ebuild')
-rw-r--r--dev-python/xgboost/xgboost-1.6.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/xgboost/xgboost-1.6.2.ebuild b/dev-python/xgboost/xgboost-1.6.2.ebuild
new file mode 100644
index 000000000..780adec11
--- /dev/null
+++ b/dev-python/xgboost/xgboost-1.6.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="XGBoost Python Package"
+HOMEPAGE="https://xgboost.readthedocs.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"