aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zarr')
-rw-r--r--dev-python/zarr/Manifest3
-rw-r--r--dev-python/zarr/metadata.xml16
-rw-r--r--dev-python/zarr/zarr-2.12.0.ebuild61
-rw-r--r--dev-python/zarr/zarr-2.14.2.ebuild61
-rw-r--r--dev-python/zarr/zarr-2.16.1.ebuild61
5 files changed, 202 insertions, 0 deletions
diff --git a/dev-python/zarr/Manifest b/dev-python/zarr/Manifest
new file mode 100644
index 000000000..bb2213da1
--- /dev/null
+++ b/dev-python/zarr/Manifest
@@ -0,0 +1,3 @@
+DIST zarr-2.12.0.tar.gz 3571172 BLAKE2B f8c628d0ff1fdb75fa46dc923de413f4de5f7aeed822a14523c3c2277b2692852f4896c80d160c503c787d510270c25fc813a9556f1a1f54ed2ffa0147f41763 SHA512 300fc20e22def9b444629c5bb7d5ae9d8178100b88f02b5dc4ddeabc2007cc9d19e7fe9b1710f3b69ebf1aa2154f7e03b11b1a78809be9285caf294d4d49c4ee
+DIST zarr-2.14.2.tar.gz 3589944 BLAKE2B 5e7de6c3a2bd9bd970b07bdfe1d51f14ad0e50bac37f2fbad91d98066d5239d237fa5af8cfef2f0a1ab4461dba4eeaed1db9fa0a4a1bfcd1757d54da4bbb15f7 SHA512 cc1eb40cd3723e87916e84f958d26df6353fc1e767e33a986068e182ad2a83c2dd7eb4939bf12ff45d4de49d822a0e6cb0afb5a5f1292d4c196f812d48939191
+DIST zarr-2.16.1.tar.gz 3597771 BLAKE2B 459f8022b3a4e3298b0f9650738713f6c13bb474ae50005b9387fefc87360f6358e4899037b26b9893d87298b14606d7b29bc1539fc8fa1479a08b30f2c8323b SHA512 e3b7c234c6376bea535d47304d83ee5b4d8b4bfc6952dde5e0bf1276833c1f427c98a7af0867f351e0139404d3729024b591a1f9b2242e219846a994e0762ee5
diff --git a/dev-python/zarr/metadata.xml b/dev-python/zarr/metadata.xml
new file mode 100644
index 000000000..036ff8b45
--- /dev/null
+++ b/dev-python/zarr/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zarr-developers/zarr-python</remote-id>
+ <remote-id type="pypi">zarr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zarr/zarr-2.12.0.ebuild b/dev-python/zarr/zarr-2.12.0.ebuild
new file mode 100644
index 000000000..f18e92d44
--- /dev/null
+++ b/dev-python/zarr/zarr-2.12.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Chunked, compressed, N-dimensional arrays for Python"
+HOMEPAGE="https://github.com/zarr-developers/zarr-python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asciitree[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ >=dev-python/numcodecs-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upsream
+# https://github.com/zarr-developers/zarr-python/issues/961
+EPYTEST_DESELECT=(
+ zarr/tests/test_core.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithPath::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithChunkStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNestedDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDBMStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithSQLiteStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNoCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBZ2Compressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBloscCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithLZMACompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithCustomMapping::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayNoCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithStoreCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithThreadSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithProcessSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreFromFilesystem::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStorePartialRead::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNested::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNestedPartialRead::test_object_arrays_vlen_bytes
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/numpydoc dev-python/sphinx-issues dev-python/sphinx-rtd-theme
diff --git a/dev-python/zarr/zarr-2.14.2.ebuild b/dev-python/zarr/zarr-2.14.2.ebuild
new file mode 100644
index 000000000..f18e92d44
--- /dev/null
+++ b/dev-python/zarr/zarr-2.14.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Chunked, compressed, N-dimensional arrays for Python"
+HOMEPAGE="https://github.com/zarr-developers/zarr-python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asciitree[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ >=dev-python/numcodecs-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upsream
+# https://github.com/zarr-developers/zarr-python/issues/961
+EPYTEST_DESELECT=(
+ zarr/tests/test_core.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithPath::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithChunkStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNestedDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDBMStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithSQLiteStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNoCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBZ2Compressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBloscCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithLZMACompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithCustomMapping::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayNoCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithStoreCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithThreadSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithProcessSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreFromFilesystem::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStorePartialRead::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNested::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNestedPartialRead::test_object_arrays_vlen_bytes
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/numpydoc dev-python/sphinx-issues dev-python/sphinx-rtd-theme
diff --git a/dev-python/zarr/zarr-2.16.1.ebuild b/dev-python/zarr/zarr-2.16.1.ebuild
new file mode 100644
index 000000000..f18e92d44
--- /dev/null
+++ b/dev-python/zarr/zarr-2.16.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Chunked, compressed, N-dimensional arrays for Python"
+HOMEPAGE="https://github.com/zarr-developers/zarr-python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asciitree[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ >=dev-python/numcodecs-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upsream
+# https://github.com/zarr-developers/zarr-python/issues/961
+EPYTEST_DESELECT=(
+ zarr/tests/test_core.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithPath::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithChunkStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNestedDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDBMStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithSQLiteStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNoCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBZ2Compressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBloscCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithLZMACompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithCustomMapping::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayNoCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithStoreCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithThreadSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithProcessSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreFromFilesystem::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStorePartialRead::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNested::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithFSStoreNestedPartialRead::test_object_arrays_vlen_bytes
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/numpydoc dev-python/sphinx-issues dev-python/sphinx-rtd-theme