aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/pythontex/pythontex-0.12.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index fb5da2dcf..76d451f9f 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -26,13 +26,14 @@ RDEPEND="${DEPEND}
TEXMF=/usr/share/texmf-site
src_prepare() {
- pwd
rm pythontex.sty
}
src_compile() {
ebegin "Compiling ${PN}"
- latex ${PN}.ins || die
+ python_optimize .
+ python_fix_shebang .
+ latex ${PN}.ins extra >/dev/null || die "Building style from ${PN}.ins failed"
eend
}