aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/pythontex/Manifest2
-rw-r--r--dev-tex/pythontex/metadata.xml14
-rw-r--r--dev-tex/pythontex/pythontex-0.14-r1.ebuild55
-rw-r--r--dev-tex/pythontex/pythontex-0.15.ebuild55
-rw-r--r--dev-tex/pythontex/pythontex-9999.ebuild56
5 files changed, 0 insertions, 182 deletions
diff --git a/dev-tex/pythontex/Manifest b/dev-tex/pythontex/Manifest
deleted file mode 100644
index ecf789f79..000000000
--- a/dev-tex/pythontex/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pythontex-0.14.tar.gz 9704671 BLAKE2B 5d4644acfb53f08cae5b45f068c363236406f42438539c52d1c2ced30b613ec71d35383e8b1233e85c6dd46acb26ce7e494990fc7c2ca2c55abd7c1a5b1bba0a SHA512 dc37e3ac112ace95d4ac253f51fe08074cf465537fa8e686637dd2342edb397e89a1e9ee1111fd6b93bcf4194b8bbbcb5cbcc5256d4c451809bf96bb28ae3db6
-DIST pythontex-0.15.tar.gz 1765050 BLAKE2B b70415e453310d97a8c50781ea2a65656cdae7a78060a8f789af36368e024ca9dd75fdb4bec55216eec982be9c31ccb0894cd258924aa5649dc46a53cb34bccb SHA512 cbca1dc9208028bfe1a8ab47f6c145ec2bd0af0ad2c733ef80e1f9ee77199670c8701d30e7634207064dd073e5456bb1d1853ce4e1729f64c44967a52111b0d8
diff --git a/dev-tex/pythontex/metadata.xml b/dev-tex/pythontex/metadata.xml
deleted file mode 100644
index 02c7c504c..000000000
--- a/dev-tex/pythontex/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <use>
- <flag name="highlighting">PLEASE FIX MY DESCRIPTION</flag>
- </use>
- <upstream>
- <remote-id type="github">gpoore/pythontex</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-tex/pythontex/pythontex-0.14-r1.ebuild b/dev-tex/pythontex/pythontex-0.14-r1.ebuild
deleted file mode 100644
index 63645e881..000000000
--- a/dev-tex/pythontex/pythontex-0.14-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-
-inherit latex-package python-r1
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS="~amd64"
-IUSE="highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-texlive/texlive-latex"
-RDEPEND="${DEPEND}
- dev-texlive/texlive-latex
- highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
- cd ${PN} || die
- ebegin "Compiling ${PN}"
- rm ${PN}.sty || die
- VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
- eend
-}
-
-src_install() {
- dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
-
- cd ${PN} || die
-
- installation() {
- if python_is_python3; then
- python_domodule {de,}${PN}3.py
- else
- python_domodule {de,}${PN}2.py
- fi
- python_domodule ${PN}_{engines,utils}.py
- python_doscript {de,}${PN}.py syncpdb.py
- python_optimize
- }
- python_foreach_impl installation
-
- latex-package_src_doinstall dtx ins sty
-}
diff --git a/dev-tex/pythontex/pythontex-0.15.ebuild b/dev-tex/pythontex/pythontex-0.15.ebuild
deleted file mode 100644
index 6526b9fc6..000000000
--- a/dev-tex/pythontex/pythontex-0.15.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit latex-package python-r1
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS="~amd64"
-IUSE="highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-texlive/texlive-latex-2016"
-RDEPEND="${DEPEND}
- >=dev-texlive/texlive-latex-2016
- highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
- cd ${PN} || die
- ebegin "Compiling ${PN}"
- rm ${PN}.sty || die
- VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
- eend
-}
-
-src_install() {
- dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
-
- cd ${PN} || die
-
- installation() {
- if python_is_python3; then
- python_domodule {de,}${PN}3.py
- else
- python_domodule {de,}${PN}2.py
- fi
- python_domodule ${PN}_{engines,utils}.py
- python_doscript {de,}${PN}.py syncpdb.py
- python_optimize
- }
- python_foreach_impl installation
-
- latex-package_src_doinstall dtx ins sty
-}
diff --git a/dev-tex/pythontex/pythontex-9999.ebuild b/dev-tex/pythontex/pythontex-9999.ebuild
deleted file mode 100644
index b5bc2fd02..000000000
--- a/dev-tex/pythontex/pythontex-9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-
-inherit latex-package python-r1 git-r3
-
-DESCRIPTION="Fast Access to Python from within LaTeX"
-HOMEPAGE="https://github.com/gpoore/pythontex"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/gpoore/pythontex.git"
-
-SLOT="0"
-LICENSE="LPPL-1.3 BSD"
-KEYWORDS=""
-IUSE="highlighting"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-texlive/texlive-latex"
-RDEPEND="${DEPEND}
- dev-texlive/texlive-latex
- highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-
-TEXMF=/usr/share/texmf-site
-
-src_compile() {
- cd ${PN} || die
- ebegin "Compiling ${PN}"
- rm ${PN}.sty || die
- VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
- eend
-}
-
-src_install() {
- dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
-
- cd ${PN} || die
-
- installation() {
- if python_is_python3; then
- python_domodule {de,}${PN}3.py
- else
- python_domodule {de,}${PN}2.py
- fi
- python_domodule ${PN}_{engines,utils}.py
- python_doscript {de,}${PN}.py syncpdb.py
- python_optimize
- }
- python_foreach_impl installation
-
- latex-package_src_doinstall dtx ins sty
-}