aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocm-clang-ocl/rocm-clang-ocl-4.0.0-r1.ebuild')
-rw-r--r--dev-util/rocm-clang-ocl/rocm-clang-ocl-4.0.0-r1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-util/rocm-clang-ocl/rocm-clang-ocl-4.0.0-r1.ebuild b/dev-util/rocm-clang-ocl/rocm-clang-ocl-4.0.0-r1.ebuild
deleted file mode 100644
index e153f61d3..000000000
--- a/dev-util/rocm-clang-ocl/rocm-clang-ocl-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="OpenCL compilation with clang compiler"
-HOMEPAGE="https://github.com/RadeonOpenCompute/clang-ocl.git"
-SRC_URI="https://github.com/RadeonOpenCompute/clang-ocl/archive/rocm-${PV}.tar.gz -> rocm-clang-ocl-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-libs/rocm-opencl-runtime"
-DEPEND="dev-util/cmake
- dev-util/rocm-cmake
- ${RDEPEND}"
-
-S=${WORKDIR}/clang-ocl-rocm-${PV}
-
-src_prepare() {
- sed -e "s:HINTS \${CXX_COMPILER_PATH}/bin:NO_DEFAULT_PATH:" \
- -e "s:/opt/rocm/llvm/bin:${EPREFIX}/usr/lib/llvm/roc/bin:" \
- -e "/AMDDeviceLibs PATHS/s:/opt/rocm:${EPREFIX}/usr/lib/cmake/AMDDeviceLibs:" \
- -e "s:\${AMD_DEVICE_LIBS_PREFIX}/amdgcn/bitcode:${EPREFIX}/usr/lib/amdgcn/bitcode:" \
- -i CMakeLists.txt || die
-
- cmake_src_prepare
-}