aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/dandi-cli/Manifest2
-rw-r--r--dev-vcs/dandi-cli/dandi-cli-0.61.0.ebuild80
-rw-r--r--dev-vcs/dandi-cli/dandi-cli-0.61.2.ebuild81
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch30
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.55.0-hdf5.patch29
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch40
-rw-r--r--dev-vcs/dandi-cli/metadata.xml26
-rw-r--r--dev-vcs/datalad-fuse/Manifest1
-rw-r--r--dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild43
-rw-r--r--dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch15
-rw-r--r--dev-vcs/datalad-fuse/metadata.xml16
-rw-r--r--dev-vcs/datalad/Manifest4
-rw-r--r--dev-vcs/datalad/datalad-0.19.6-r1.ebuild (renamed from dev-vcs/datalad/datalad-0.15.1.ebuild)45
-rw-r--r--dev-vcs/datalad/datalad-1.0.2.ebuild (renamed from dev-vcs/datalad/datalad-0.15.2.ebuild)51
-rw-r--r--dev-vcs/datalad/metadata.xml1
15 files changed, 422 insertions, 42 deletions
diff --git a/dev-vcs/dandi-cli/Manifest b/dev-vcs/dandi-cli/Manifest
new file mode 100644
index 000000000..f84e21730
--- /dev/null
+++ b/dev-vcs/dandi-cli/Manifest
@@ -0,0 +1,2 @@
+DIST dandi-0.61.0.tar.gz 306755 BLAKE2B 8d279fddf4a9c390c91d09915d978f5709c297bb4284e8c8f3026ef9c94a9b2bab4b24409ff1d915550ab2564f8398a1afb236b226a41303264898de51deed42 SHA512 3cbd5c81c024cfca01c94fd2f9c794b22170f830a39c283f5cde1dfd998447287559457e324f81f46154fa38bf065720736da3be13a5668bc7453d091dd51869
+DIST dandi-0.61.2.tar.gz 306867 BLAKE2B 9a51c26f36d462e518241d40604726973727f17c70855136b6ea8e8402fb2c30ecc3adbbf7db6ed967bdb8c63a11da0809c09ae61f3a4996784b0b2083c1ec3a SHA512 9f4f3a02e62a3c4af3496a29faa18c696263e71dd2baf56c2925696c09e4c633a3a28a1fe30329764b98cba3006e4ccfe0884f5bae3d580f643f4cf946b2d291
diff --git a/dev-vcs/dandi-cli/dandi-cli-0.61.0.ebuild b/dev-vcs/dandi-cli/dandi-cli-0.61.0.ebuild
new file mode 100644
index 000000000..35ac320f5
--- /dev/null
+++ b/dev-vcs/dandi-cli/dandi-cli-0.61.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+MY_PN="dandi"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DANDI command line client to facilitate common operations"
+HOMEPAGE="https://github.com/dandi/dandi-cli"
+SRC_URI="$(pypi_sdist_url dandi)"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test etelemetry"
+
+RDEPEND="
+ >=dev-python/dandi-schema-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.0.0[${PYTHON_USEDEP}]
+ >=sci-biology/bidsschematools-0.7.0[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/fscacher[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/interleave[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/nwbinspector[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyout[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/semantic-version[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+ >=dev-python/zarr_checksum-0.4.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/anys[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
+ )
+"
+# Upstream might be amenable to dropping opencv:
+# https://github.com/dandi/dandi-cli/issues/944
+
+S="${WORKDIR}/${MY_P}"
+
+EPYTEST_DESELECT=(
+ # Reported upstream:
+ # https://github.com/dandi/dandi-cli/issues/1394
+ dandi/cli/tests/test_command.py::test_no_heavy_imports
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ epytest
+}
diff --git a/dev-vcs/dandi-cli/dandi-cli-0.61.2.ebuild b/dev-vcs/dandi-cli/dandi-cli-0.61.2.ebuild
new file mode 100644
index 000000000..760fb32b4
--- /dev/null
+++ b/dev-vcs/dandi-cli/dandi-cli-0.61.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+MY_PN="dandi"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DANDI command line client to facilitate common operations"
+HOMEPAGE="https://github.com/dandi/dandi-cli"
+SRC_URI="$(pypi_sdist_url dandi)"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test etelemetry"
+
+RDEPEND="
+ >=dev-python/dandi-schema-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.0.0[${PYTHON_USEDEP}]
+ >=sci-biology/bidsschematools-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/zarr_checksum-0.4.0[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/fscacher[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/interleave[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/nwbinspector[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyout[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/semantic-version[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/anys[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
+ )
+"
+# Upstream might be amenable to dropping opencv:
+# https://github.com/dandi/dandi-cli/issues/944
+
+EPYTEST_DESELECT=(
+ # Reported upstream:
+ # https://github.com/dandi/dandi-cli/issues/1394
+ dandi/cli/tests/test_command.py::test_no_heavy_imports
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ epytest
+}
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch
new file mode 100644
index 000000000..6822e1abf
--- /dev/null
+++ b/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch
@@ -0,0 +1,30 @@
+--- a/dandi/utils.py 2021-09-21 11:51:39.799524534 -0400
++++ b/dandi/utils.py 2021-10-06 04:58:00.506440719 -0400
+@@ -734,27 +734,4 @@
+ def check_dandi_version():
+ if os.environ.get("DANDI_NO_ET"):
+ return
+- try:
+- import etelemetry
+-
+- try:
+- etelemetry.check_available_version(
+- "dandi/dandi-cli", __version__, lgr=lgr, raise_exception=True
+- )
+- except etelemetry.client.BadVersionError:
+- # note: SystemExit is based of BaseException, so is not Exception
+- raise SystemExit(
+- "DANDI CLI has detected that you are using a version that is known to "
+- "contain bugs, is incompatible with our current data archive, or has "
+- "other significant performance limitations. "
+- "To continue using DANDI CLI, please upgrade your dandi client to a newer "
+- "version (e.g., using pip install --upgrade dandi if you installed using pip). "
+- "If you have any issues, please contact the DANDI "
+- "helpdesk at https://github.com/dandi/helpdesk/issues/new/choose ."
+- )
+- except Exception as exc:
+- lgr.warning(
+- "Failed to check for a more recent version available with etelemetry: %s",
+- exc,
+- )
+ os.environ["DANDI_NO_ET"] = "1"
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.55.0-hdf5.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.55.0-hdf5.patch
new file mode 100644
index 000000000..4cd55ca7e
--- /dev/null
+++ b/dev-vcs/dandi-cli/files/dandi-cli-0.55.0-hdf5.patch
@@ -0,0 +1,29 @@
+From d16bf0855e9ef7c029e8aca969ddfa04c1d7fdfd Mon Sep 17 00:00:00 2001
+From: "John T. Wodder II" <git@varonathe.org>
+Date: Thu, 25 May 2023 14:17:36 -0400
+Subject: [PATCH] Fix test for newer hdf5
+
+---
+ dandi/tests/test_files.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/dandi/tests/test_files.py b/dandi/tests/test_files.py
+index 4dbf0f223..3e44cf6b1 100644
+--- a/dandi/tests/test_files.py
++++ b/dandi/tests/test_files.py
+@@ -374,7 +374,14 @@ def test_validate_bogus(tmp_path):
+ errors = dandi_file(path).get_validation_errors()
+ # ATM we would get 2 errors -- since could not be open in two places,
+ # but that would be too rigid to test. Let's just see that we have expected errors
+- assert any(e.message.startswith("Unable to open file") for e in errors)
++ assert any(
++ e.message.startswith(
++ ("Unable to open file", "Unable to synchronously open file")
++ )
++ for e in errors
++ )
++ # Recent versions of hdf5 changed the error message, hence the need to
++ # check for two different patterns.
+
+
+ def test_upload_zarr(new_dandiset, tmp_path):
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch
new file mode 100644
index 000000000..4d4f42a03
--- /dev/null
+++ b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch
@@ -0,0 +1,40 @@
+diff --git a/dandi/files/bases.py b/dandi/files/bases.py
+index 45f5929f..38bde34f 100644
+--- a/dandi/files/bases.py
++++ b/dandi/files/bases.py
+@@ -18,7 +18,6 @@ from dandischema.digests.dandietag import DandiETag
+ from dandischema.models import BareAsset, CommonModel
+ from dandischema.models import Dandiset as DandisetMeta
+ from dandischema.models import get_schema_version
+-from etelemetry import get_project
+ from packaging.version import Version
+ from pydantic import ValidationError
+ import requests
+@@ -737,6 +736,7 @@ def _get_nwb_inspector_version():
+ _current_nwbinspector_version = get_package_version(name="nwbinspector")
+ # Ensure latest version of NWB Inspector is installed and used client-side
+ try:
++ from etelemetry import get_project
+ max_version = Version(
+ get_project(repo="NeurodataWithoutBorders/nwbinspector")["version"]
+ )
+diff --git a/setup.cfg b/setup.cfg
+--- a/setup.cfg 2024-01-09 14:08:33.952653200 -0500
++++ b/setup.cfg 2024-01-25 01:45:34.594335960 -0500
+@@ -34,7 +34,6 @@
+ click >= 7.1
+ click-didyoumean
+ dandischema ~= 0.8.0
+- etelemetry >= 0.2.2
+ fasteners
+ fscacher >= 0.3.0
+ hdmf != 3.5.0
+@@ -147,9 +146,6 @@
+ [mypy-click_didyoumean.*]
+ ignore_missing_imports = True
+
+-[mypy-etelemetry.*]
+-ignore_missing_imports = True
+-
+ [mypy-fasteners.*]
+ ignore_missing_imports = True
diff --git a/dev-vcs/dandi-cli/metadata.xml b/dev-vcs/dandi-cli/metadata.xml
new file mode 100644
index 000000000..9565a2184
--- /dev/null
+++ b/dev-vcs/dandi-cli/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides a dandi command line utility with a basic interface
+ which should assist you in preparing and uploading your data to and/or
+ obtaining data from the http://dandiarchive.org . Each of the commands
+ has a set of options to alter their behavior. Please run
+ `dandi COMMAND --help` to get more information
+ </longdescription>
+ <use>
+ <flag name="etelemetry">version checking to respect server schema version</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">dandi/dandi-cli</remote-id>
+ <remote-id type="pypi">dandi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/datalad-fuse/Manifest b/dev-vcs/datalad-fuse/Manifest
new file mode 100644
index 000000000..cebf299ec
--- /dev/null
+++ b/dev-vcs/datalad-fuse/Manifest
@@ -0,0 +1 @@
+DIST datalad-fuse-0.5.1.gh.tar.gz 66846 BLAKE2B 7b6311060bc8434ff48006775199c8bcac30a37feb55a516dd5df754a2c81f062bcd6717f977365d4db08f97e587fc105e7721ff54e08ae90db159b2fb1c81c3 SHA512 9e479008325b6673bb0714dcfc86776361a6764f2218ed70ca229a76ac04e352c76b7c41e1aba13939ccfec186f2ad00b0c1a15eefc42f9b81af4041fcb4fe32
diff --git a/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild b/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild
new file mode 100644
index 000000000..1359f4e0d
--- /dev/null
+++ b/dev-vcs/datalad-fuse/datalad-fuse-0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Keep code, data, containers under control with git and git-annex"
+HOMEPAGE="https://github.com/datalad/datalad"
+SRC_URI="https://github.com/datalad/datalad-fuse/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/aiohttp-retry[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/methodtools[${PYTHON_USEDEP}]
+ dev-python/linesep[${PYTHON_USEDEP}]
+ dev-vcs/datalad[${PYTHON_USEDEP}]
+ sys-fs/fuse
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${P}-git_config.patch"
+)
+
+python_test() {
+ #git init -q || die
+ #git config --global user.email "placeholder@gentoo.org" || die
+ #git config --global user.name "Place Holder" || die
+ #git add . || die
+ #git commit -m "init" || die
+ ##GIT_AUTHOR_NAME="Place Holder" GIT_AUTHOR_EMAIL="placeholder@gentoo.org" epytest
+ ##export GIT_AUTHOR_NAME="Place Holder"
+ ##export GIT_AUTHOR_EMAIL="placeholder@gentoo.org"
+ epytest
+}
diff --git a/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch b/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch
new file mode 100644
index 000000000..f62fc412e
--- /dev/null
+++ b/dev-vcs/datalad-fuse/files/datalad-fuse-0.5.1-git_config.patch
@@ -0,0 +1,15 @@
+Upstreamed and perhaps removable for future releases:
+https://github.com/datalad/datalad-fuse/pull/113
+diff --git a/datalad_fuse/tests/test_fsspec_head.py b/datalad_fuse/tests/test_fsspec_head.py
+index 75a6efc..1ffc60f 100644
+--- a/datalad_fuse/tests/test_fsspec_head.py
++++ b/datalad_fuse/tests/test_fsspec_head.py
+@@ -131,6 +131,8 @@ def test_git_repo(tmp_path):
+ TEXT = (Path(__file__).with_name("data") / "text.txt").read_bytes()
+ (tmp_path / "text.txt").write_bytes(TEXT)
+ subprocess.run(["git", "add", "text.txt"], cwd=tmp_path, check=True)
++ subprocess.run(["git", "config", "user.email", "place@holder.org"], cwd=tmp_path, check=True)
++ subprocess.run(["git", "config", "user.name", "Place Holder"], cwd=tmp_path, check=True)
+ subprocess.run(["git", "commit", "-m", "Add a file"], cwd=tmp_path, check=True)
+ ds = Dataset(tmp_path)
+ assert_in_results(
diff --git a/dev-vcs/datalad-fuse/metadata.xml b/dev-vcs/datalad-fuse/metadata.xml
new file mode 100644
index 000000000..97f1a33f3
--- /dev/null
+++ b/dev-vcs/datalad-fuse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">datalad/datalad-fuse</remote-id>
+ <remote-id type="pypi">datalad-fuse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/datalad/Manifest b/dev-vcs/datalad/Manifest
index c4147a574..6d9dda572 100644
--- a/dev-vcs/datalad/Manifest
+++ b/dev-vcs/datalad/Manifest
@@ -1,2 +1,2 @@
-DIST datalad-0.15.1.tar.gz 1357778 BLAKE2B 7c12c3ff1bd8d260e8e7cfd9e477a1f0798f6fc0fbdbc335229bcf88362ebc7280eeb92bb59c45e0f66677297680e4d8d7bc8f56c7ac171f921bc389c1ceef7c SHA512 d5ae7859486748cbf40bd27f3351fa5620b8342c6a4347b8e3e0cb331de5fa33b9384071adbb899fd7878641a210a11b360a9ea68d0c7437eae709244fa08fd1
-DIST datalad-0.15.2.tar.gz 1361038 BLAKE2B c515b374f0781693ed0f1d0d2c260a0bdb1c9e998b782a2232c501b4ab7c022adc38f00a79d0aed04ffde4ade5c696705d53bf16dbaec2378c74ef4ab35a7a15 SHA512 f0206855439c2d376172218ec6bf1ffa3277508256a5a49a2ec65a57bb5720e039481329c16459ed62eb1c9ed0126dc178ca34fa2c3b8dfdf8b8a0706a2b8658
+DIST datalad-0.19.6.tar.gz 1420979 BLAKE2B 49d8e19449652f284f89f99e6696c6d1abf7ddcc58a8eb00004c657be38ce2532ed9c11855dca4a0a8f82c55fbf1633f53ff2bdea063fd18ad946145d27a3404 SHA512 db7cd807a8106727f0b6f587be8c0ce3abcf0dc7cf72b4757e6b44650adca05482e6b0a6c1719050fba37660dcd5de2a6f27df044a8db180ac6855ee7ff8cbda
+DIST datalad-1.0.2.tar.gz 1420919 BLAKE2B 0a5209b11cb2eaa710a423be72ad500a6b0041d7248d22be469d5e2ad7699fad30600f34f52d32c59bf069c3c5698f020fa0b7a07ce7b63e1154b548e63a6e73 SHA512 8c1bc7742687699ac21b5495b3dd6ef495da172e7c1d4e48206fd957943b18cf7c21887f4bae623b5352c34fa5e1192789b1d2a8c23883e3617e47946b8789cf
diff --git a/dev-vcs/datalad/datalad-0.15.1.ebuild b/dev-vcs/datalad/datalad-0.19.6-r1.ebuild
index 2322ac254..c95bc935f 100644
--- a/dev-vcs/datalad/datalad-0.15.1.ebuild
+++ b/dev-vcs/datalad/datalad-0.19.6-r1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
-inherit distutils-r1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
DESCRIPTION="Keep code, data, containers under control with git and git-annex"
HOMEPAGE="https://github.com/datalad/datalad"
-SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -17,21 +18,22 @@ IUSE="test +downloaders +metadata +publish misc"
RESTRICT="!test? ( test )"
RDEPEND="
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
app-arch/p7zip
+ app-arch/patool[${PYTHON_USEDEP}]
dev-python/annexremote[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
dev-python/fasteners[${PYTHON_USEDEP}]
- app-arch/patool[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/wraps[${PYTHON_USEDEP}]
+ dev-vcs/git-annex
downloaders? (
- dev-python/boto[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/keyrings_alt[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
dev-python/msgpack[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
@@ -46,23 +48,26 @@ RDEPEND="
)
publish? (
dev-vcs/python-gitlab[${PYTHON_USEDEP}]
- dev-python/PyGithub[${PYTHON_USEDEP}]
)
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
test? (
+ ${RDEPEND}
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
dev-python/vcrpy[${PYTHON_USEDEP}]
)
"
+# Also wants test dep:
+# dev-python/types-requests
+# dev-python/types-python-dateutil
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_test() {
- export DATALAD_TESTS_NONETWORK=1
- ${EPYTHON} -m nose -s -v -A "not(integration or usecase or slow or network or turtle)" datalad || die
- # Full test suite takes for ever:
- # ${EPYTHON} -m nose -s -v datalad || die
+ local -x DATALAD_TESTS_NONETWORK=1
+ # see test groups in "tox.ini"
+ epytest -k "not turtle and not slow and not usecase"
}
diff --git a/dev-vcs/datalad/datalad-0.15.2.ebuild b/dev-vcs/datalad/datalad-1.0.2.ebuild
index 2322ac254..de5b6cd6a 100644
--- a/dev-vcs/datalad/datalad-0.15.2.ebuild
+++ b/dev-vcs/datalad/datalad-1.0.2.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
-inherit distutils-r1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
DESCRIPTION="Keep code, data, containers under control with git and git-annex"
HOMEPAGE="https://github.com/datalad/datalad"
-SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -17,21 +18,22 @@ IUSE="test +downloaders +metadata +publish misc"
RESTRICT="!test? ( test )"
RDEPEND="
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
app-arch/p7zip
+ app-arch/patool[${PYTHON_USEDEP}]
dev-python/annexremote[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
dev-python/fasteners[${PYTHON_USEDEP}]
- app-arch/patool[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/wraps[${PYTHON_USEDEP}]
+ dev-vcs/git-annex
downloaders? (
- dev-python/boto[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/keyrings_alt[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
dev-python/msgpack[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
@@ -46,23 +48,32 @@ RDEPEND="
)
publish? (
dev-vcs/python-gitlab[${PYTHON_USEDEP}]
- dev-python/PyGithub[${PYTHON_USEDEP}]
)
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
test? (
+ ${RDEPEND}
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
dev-python/vcrpy[${PYTHON_USEDEP}]
)
"
+# Also wants test dep:
+# dev-python/types-requests
+# dev-python/types-python-dateutil
+
+distutils_enable_tests pytest
-distutils_enable_tests nose
+EPYTEST_DESELECT=(
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_frozen_time
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_frozen_time_with_func
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_hello
+)
python_test() {
- export DATALAD_TESTS_NONETWORK=1
- ${EPYTHON} -m nose -s -v -A "not(integration or usecase or slow or network or turtle)" datalad || die
- # Full test suite takes for ever:
- # ${EPYTHON} -m nose -s -v datalad || die
+ local -x DATALAD_TESTS_NONETWORK=1
+ # see test groups in "tox.ini"
+ epytest -k "not turtle and not slow and not usecase"
}
diff --git a/dev-vcs/datalad/metadata.xml b/dev-vcs/datalad/metadata.xml
index 8a6c00a2d..9c40d4f36 100644
--- a/dev-vcs/datalad/metadata.xml
+++ b/dev-vcs/datalad/metadata.xml
@@ -26,5 +26,6 @@
</use>
<upstream>
<remote-id type="github">datalad/datalad</remote-id>
+ <remote-id type="pypi">datalad</remote-id>
</upstream>
</pkgmetadata>