aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/gcb/gcb-1.5.6.ebuild')
-rw-r--r--net-firewall/gcb/gcb-1.5.6.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-firewall/gcb/gcb-1.5.6.ebuild b/net-firewall/gcb/gcb-1.5.6.ebuild
index 50d3117d8..2f780fc2d 100644
--- a/net-firewall/gcb/gcb-1.5.6.ebuild
+++ b/net-firewall/gcb/gcb-1.5.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
-inherit eutils autotools
+inherit autotools eutils
DESCRIPTION="Generic Connection Brokering for communications over firewall/NAT"
HOMEPAGE="http://www.cs.wisc.edu/condor/gcb"
@@ -15,19 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
src_prepare() {
epatch "${FILESDIR}"/${P}-shared.patch
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NOTICE.txt doc/protocol.txt
if use doc; then
insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die
+ doins doc/*.pdf
fi
}