aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cernbox-client/files/owncloud-client-3.1.0.9872-no_cmake_fetch.patch')
-rw-r--r--net-misc/cernbox-client/files/owncloud-client-3.1.0.9872-no_cmake_fetch.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/files/owncloud-client-3.1.0.9872-no_cmake_fetch.patch b/net-misc/cernbox-client/files/owncloud-client-3.1.0.9872-no_cmake_fetch.patch
new file mode 100644
index 000000000..d9762292e
--- /dev/null
+++ b/net-misc/cernbox-client/files/owncloud-client-3.1.0.9872-no_cmake_fetch.patch
@@ -0,0 +1,17 @@
+Index: ownCloud-3.1.0.9872/src/libsync/CMakeLists.txt
+--- ownCloud-3.1.0.9872/src/libsync/CMakeLists.txt.orig
++++ ownCloud-3.1.0.9872/src/libsync/CMakeLists.txt
+@@ -3,12 +3,7 @@ set(LibreGraphAPIVersion v0.13.2)
+ find_package(LibreGraphAPI QUIET)
+ if (NOT TARGET OpenAPI::LibreGraphAPI)
+ message(WARNING "Failed to find system OpenAPI::LibreGraphAPI: fetching ${LibreGraphAPIVersion}")
+- include(FetchContent)
+- FetchContent_Populate(LibreGraphAPISrc
+- QUIET
+- GIT_REPOSITORY https://github.com/owncloud/libre-graph-api-cpp-qt-client.git
+- GIT_TAG ${LibreGraphAPIVersion})
+- add_subdirectory(${libregraphapisrc_SOURCE_DIR}/client ${libregraphapisrc_BINARY_DIR}/client EXCLUDE_FROM_ALL)
++ add_subdirectory(libregraphapisrc-src/client libregraphapisrc-src/client EXCLUDE_FROM_ALL)
+ endif()
+
+ set(libsync_SRCS