aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/libthesky/libthesky-0.4.2.ebuild')
-rw-r--r--sci-astronomy/libthesky/libthesky-0.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-astronomy/libthesky/libthesky-0.4.2.ebuild b/sci-astronomy/libthesky/libthesky-0.4.2.ebuild
new file mode 100644
index 000000000..c7d2bd0c3
--- /dev/null
+++ b/sci-astronomy/libthesky/libthesky-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE=Release
+CMAKE_MAKEFILE_GENERATOR="emake"
+inherit cmake fortran-2
+
+DESCRIPTION="Fortran library to compute positions of celestial bodies"
+HOMEPAGE="http://libthesky.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz
+ https://downloads.sourceforge.net/${PN}/libthesky-data-20160409.tar.bz2
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sci-libs/libsufr[static-libs?]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ gunzip -r "${S}"/man || die
+ mv "${WORKDIR}"/data "${S}" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCREATE_SHAREDLIB=ON
+ -DCREATE_STATICLIB=$(usex static-libs)
+ )
+ cmake_src_configure
+}