aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/montage/montage-3.3.ebuild')
-rw-r--r--sci-astronomy/montage/montage-3.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/montage/montage-3.3.ebuild b/sci-astronomy/montage/montage-3.3.ebuild
new file mode 100644
index 000000000..370bf1a73
--- /dev/null
+++ b/sci-astronomy/montage/montage-3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MYP=Montage_v${PV}
+
+DESCRIPTION="Astronomical image mosaic engine"
+HOMEPAGE="http://montage.ipac.caltech.edu/"
+SRC_URI="http://montage.ipac.caltech.edu/download/${MYP}.tar.gz
+ doc? ( http://montage.ipac.caltech.edu/docs/docs.tar.gz -> ${PN}-docs.tar.gz )"
+
+LICENSE="Montage"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+IUSE="doc mpi"
+
+# unfortunate upstream patching, cfitsio, wcstools, jpeg
+# see docs/ExternalLibraries
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ use doc && mv "${WORKDIR}"/docs/* docs/
+ sed -i \
+ -e "/CC.*=/s:\(gcc\|cc\):$(tc-getCC):g" \
+ -e "/CFLAGS.*=/s:-g:${CFLAGS}:g" \
+ -e "s:ar q:$(tc-getAR) q:g" \
+ $(find . -name Makefile) || die
+ if use mpi; then
+ sed -i \
+ -e 's:# MPICC:MPICC:' \
+ -e 's:# BINS:BINS:' \
+ Montage/Makefile || die
+ fi
+}
+
+src_install () {
+ dobin bin/*
+ dodoc README ChangeHistory
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/*
+ fi
+}