aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/psfex/psfex-9999.ebuild')
-rw-r--r--sci-astronomy/psfex/psfex-9999.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sci-astronomy/psfex/psfex-9999.ebuild b/sci-astronomy/psfex/psfex-9999.ebuild
deleted file mode 100644
index 84c1b4262..000000000
--- a/sci-astronomy/psfex/psfex-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit subversion autotools
-
-ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
-ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
-SRC_URI=""
-KEYWORDS=""
-
-DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
-HOMEPAGE="http://www.astromatic.net/software/psfex"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="doc threads plplot"
-
-RDEPEND="
- sci-libs/atlas[lapack,threads=]
- sci-libs/fftw:3.0
- plplot? ( sci-libs/plplot:= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- local mycblas=atlcblas myclapack=atlclapack
- if use threads; then
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
- mycblas=ptcblas
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
- myclapack=ptclapack
- fi
- # fix the configure and not the acx_atlas.m4. the eautoreconf will
- # produce a configure giving a wrong install Makefile target (to fix)
- sed -e "s/-lcblas/-l${mycblas}/g" \
- -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
- -e "s/-llapack/-l${myclapack}/g" \
- -e "s/\(lapack_lib=\).*/\1${myclapack}/g" \
- -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
- -i acx_atlas.m4 || die
-
- eautoreconf
- subversion_src_prepare
-}
-
-src_configure() {
- econf \
- --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
- $(use_enable plplot) \
- $(use_enable threads)
-}
-
-src_install () {
- default
- use doc && dodoc doc/*
-}