aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/scamp/scamp-1.7.0-r2.ebuild')
-rw-r--r--sci-astronomy/scamp/scamp-1.7.0-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild b/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild
new file mode 100644
index 000000000..6d3347da9
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads plplot"
+
+RDEPEND=">=sci-astronomy/cdsclient-3.4
+ virtual/cblas
+ sci-libs/atlas
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ configure || die "sed acx_atlas.m4 failed"
+ epatch "${FILESDIR}"/${PV}-plplot599.patch
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EROOT}/usr/include/atlas" \
+ $(use_with plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*,pdf
+}