aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/skymaker')
-rw-r--r--sci-astronomy/skymaker/ChangeLog7
-rw-r--r--sci-astronomy/skymaker/Manifest1
-rw-r--r--sci-astronomy/skymaker/files/skymaker-configure.patch40
-rw-r--r--sci-astronomy/skymaker/skymaker-3.3.3.ebuild27
-rw-r--r--sci-astronomy/skymaker/skymaker-9999.ebuild14
5 files changed, 12 insertions, 77 deletions
diff --git a/sci-astronomy/skymaker/ChangeLog b/sci-astronomy/skymaker/ChangeLog
index 54eb51c1c..a1747aa3a 100644
--- a/sci-astronomy/skymaker/ChangeLog
+++ b/sci-astronomy/skymaker/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-astronomy/skymaker
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 27 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> -Manifest,
+ -files/skymaker-configure.patch, -skymaker-3.3.3.ebuild, skymaker-9999.ebuild:
+ sci-astronomy/skymaker: EAPI-5, autotools-utils
+
*skymaker-9999 (04 Jul 2012)
04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> skymaker-3.3.3.ebuild,
@@ -23,4 +27,3 @@
20 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org> ChangeLog:
Initial import
-
diff --git a/sci-astronomy/skymaker/Manifest b/sci-astronomy/skymaker/Manifest
deleted file mode 100644
index c4eaf693d..000000000
--- a/sci-astronomy/skymaker/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST skymaker-3.3.3.tar.gz 415740 SHA256 75ddcfcc577591b3ad430171fa867cc7a573bb93f541fd82ef6ebe873c1816f4 SHA512 3980275af2ecf1c35057e61f6368b4bb3ee1428fa7fca366bb8bb373efd70351c4b3caac0e930a3f43aad61440844963e2d684f0f31d9d6517842ba0d61bf93b WHIRLPOOL 4496b40ab6ea19da5e3647cf8f985fa9e443795d20e1a5e0361ab95be1b6b484e88a65e93c47457de39edbab866e72bdba2c4fc919597072741ec0475444a7d7
diff --git a/sci-astronomy/skymaker/files/skymaker-configure.patch b/sci-astronomy/skymaker/files/skymaker-configure.patch
deleted file mode 100644
index 7f7bdb1ba..000000000
--- a/sci-astronomy/skymaker/files/skymaker-configure.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- configure.ac.orig 2009-03-25 18:16:52.000000000 +0000
-+++ configure.ac 2009-03-25 18:17:35.000000000 +0000
-@@ -22,37 +22,18 @@
-
- # Include macros
- sinclude(acx_fftw.m4)
--sinclude(acx_prog_cc_optim.m4)
- sinclude(acx_pthread.m4)
-
- # Display pakage and version number
- AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
-
--# Initialize the list of compilers to consider
--cclist="cc gcc"
--# Backup and reset the input CFLAGS
--mycflags="$CFLAGS"
--CFLAGS=""
--
--# Provide special option for the Linux Intel C compiler
--AC_MSG_CHECKING([for Linux Intel C compiler mode])
--AC_ARG_ENABLE(icc,
-- [AS_HELP_STRING(--enable-icc,Enable special mode for compilation with the Intel compiler \
--(off by default))],
-- use_icc="yes"
-- cclist="icc $cclist"
-- AC_MSG_RESULT([yes]),
-- use_icc="no"
-- AC_MSG_RESULT([no]))
-
- # Checks for programs.
- # GCC is chosen last because it is likely to yield less optimized code
- AC_LANG(C)
--AC_PROG_CC([$cclist])
- # C Compiler: Check that it is ANSI C and POSIX-compliant
- AM_PROG_CC_STDC
- AC_ISC_POSIX
--ACX_PROG_CC_OPTIM
- AC_DISABLE_STATIC
- #AC_DISABLE_SHARED
- AC_PROG_LIBTOOL
diff --git a/sci-astronomy/skymaker/skymaker-3.3.3.ebuild b/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
deleted file mode 100644
index 49867323f..000000000
--- a/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit autotools eutils
-
-DESCRIPTION="Program that simulates astronomical images"
-HOMEPAGE="http://www.astromatic.net/software/skymaker"
-SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="threads"
-
-DEPEND=">=sci-libs/fftw-3"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-configure.patch
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable threads)
-}
diff --git a/sci-astronomy/skymaker/skymaker-9999.ebuild b/sci-astronomy/skymaker/skymaker-9999.ebuild
index d88239110..e50a24878 100644
--- a/sci-astronomy/skymaker/skymaker-9999.ebuild
+++ b/sci-astronomy/skymaker/skymaker-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
if [[ ${PV} == "9999" ]] ; then
_SVN=subversion
@@ -14,7 +14,10 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit ${_SVN} autotools
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit ${_SVN} autotools-utils
DESCRIPTION="Program that simulates astronomical images"
HOMEPAGE="http://www.astromatic.net/software/skymaker"
@@ -27,10 +30,7 @@ IUSE="threads"
RDEPEND="sci-libs/fftw:3.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- eautoreconf
-}
-
src_configure() {
- econf $(use_enable threads)
+ local myeconfargs=( $(use_enable threads) )
+ autotools-utils_src_configure
}