aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stuff')
-rw-r--r--sci-astronomy/stuff/Manifest1
-rw-r--r--sci-astronomy/stuff/stuff-1.26.0.ebuild35
-rw-r--r--sci-astronomy/stuff/stuff-9999.ebuild31
3 files changed, 14 insertions, 53 deletions
diff --git a/sci-astronomy/stuff/Manifest b/sci-astronomy/stuff/Manifest
deleted file mode 100644
index 66d2eaba0..000000000
--- a/sci-astronomy/stuff/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST stuff-1.26.0.tar.gz 4110495 SHA256 55b2e646f80653c09f023c3627c69126a4da5f9d73b30867bce91bb4465cd1eb SHA512 6b71112e29d06807c8fc880bd33032a08810554afa563f27d5af19a45293b780ab0b7827ad84ad7942bed28fe3b03bb6c1fa3983667d1fbcbb467b32653203f2 WHIRLPOOL daf35d1fc1d26cf248d3ebc010a907df860ade582195f3267d8224e362545fa7b96fd9bacd081f06bb9655b0a4a459e36a1263466b504bae6ce32957b6a7f462
diff --git a/sci-astronomy/stuff/stuff-1.26.0.ebuild b/sci-astronomy/stuff/stuff-1.26.0.ebuild
deleted file mode 100644
index 1f57f85a8..000000000
--- a/sci-astronomy/stuff/stuff-1.26.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-#AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils
-
-DESCRIPTION="Tool for automatic generation of astronomical catalogs"
-HOMEPAGE="http://www.astromatic.net/software/stuff/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="threads"
-
-RDEPEND="sci-libs/fftw:3.0"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
-}
diff --git a/sci-astronomy/stuff/stuff-9999.ebuild b/sci-astronomy/stuff/stuff-9999.ebuild
index 1f57f85a8..b7eff80fa 100644
--- a/sci-astronomy/stuff/stuff-9999.ebuild
+++ b/sci-astronomy/stuff/stuff-9999.ebuild
@@ -1,23 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit subversion
-#AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
+ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
-inherit autotools-utils
+SRC_URI=""
+KEYWORDS=""
DESCRIPTION="Tool for automatic generation of astronomical catalogs"
HOMEPAGE="http://www.astromatic.net/software/stuff/"
@@ -26,10 +19,14 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="threads"
-RDEPEND="sci-libs/fftw:3.0"
+RDEPEND=""
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ subversion_src_prepare
+}
+
src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
+ econf $(use_enable threads)
}