aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/swarp')
-rw-r--r--sci-astronomy/swarp/ChangeLog2
-rw-r--r--sci-astronomy/swarp/Manifest6
-rw-r--r--sci-astronomy/swarp/swarp-2.15.6.ebuild12
3 files changed, 10 insertions, 10 deletions
diff --git a/sci-astronomy/swarp/ChangeLog b/sci-astronomy/swarp/ChangeLog
index 78d44aba0..4138b082b 100644
--- a/sci-astronomy/swarp/ChangeLog
+++ b/sci-astronomy/swarp/ChangeLog
@@ -3,7 +3,7 @@
# $Header: $
-* swarp-2.15.6 (02 Dec 2005)
+*swarp-2.15.6 (02 Dec 2005)
02 Dec 2005; Sebastien Fabbro <seb@ist.utl.pt> swarp-2.15.6.ebuild
Initial import. Close bug #65685.
diff --git a/sci-astronomy/swarp/Manifest b/sci-astronomy/swarp/Manifest
index a82690266..1bc2fea42 100644
--- a/sci-astronomy/swarp/Manifest
+++ b/sci-astronomy/swarp/Manifest
@@ -1,4 +1,4 @@
-MD5 aabe65c29b196e2354aee2037f6c3f26 swarp-2.15.6.ebuild 1138
-MD5 79b02536bd71bf7a4f217cda0ec8edb4 metadata.xml 410
-MD5 82864d3f9ef6d22781f93f5bc56f1ec6 ChangeLog 259
+MD5 d8f338413648f675021b3489445a9222 ChangeLog 258
MD5 55cc4a25b090f2fbac8ee76ff19eb5e0 files/digest-swarp-2.15.6 65
+MD5 79b02536bd71bf7a4f217cda0ec8edb4 metadata.xml 410
+MD5 fb798d8b187ce043bb60e1cba34198a5 swarp-2.15.6.ebuild 1124
diff --git a/sci-astronomy/swarp/swarp-2.15.6.ebuild b/sci-astronomy/swarp/swarp-2.15.6.ebuild
index 852341501..a59341bfe 100644
--- a/sci-astronomy/swarp/swarp-2.15.6.ebuild
+++ b/sci-astronomy/swarp/swarp-2.15.6.ebuild
@@ -10,17 +10,17 @@ SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="static doc threads mpi icc"
DEPEND="mpi? ( || ( sys-cluster/lam-mpi sys-cluster/mpich ) )
- icc? ( dev-lang/icc >= 9 )
- "
+ icc? ( dev-lang/icc >= 9 )"
+
# mpi stuff untested.
src_compile() {
# trust swarp cflags to be optimized.
filter-flags ${CFLAGS}
- # --disable-threads does not work
- # note we could calculate a number of threads (~= ncpu)
+ # --disable-threads does not compile
+ # todo: calculate a number of threads (~= ncpu)
local myconf=""
use threads && myconf="--enable-threads "
! use mpi && export MPICC="gcc"
@@ -37,7 +37,7 @@ src_install () {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS ChangeLog COPYING HISTORY README THANKS
if use doc; then
- insinto /usr/share/doc/${PF}
+ insinto /usr/share/doc/${PF}
doins doc/*
fi
}