aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/astrometry/ChangeLog5
-rw-r--r--sci-astronomy/astrometry/astrometry-0.43.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/sci-astronomy/astrometry/ChangeLog b/sci-astronomy/astrometry/ChangeLog
index afb42de9e..dfd71da12 100644
--- a/sci-astronomy/astrometry/ChangeLog
+++ b/sci-astronomy/astrometry/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-astronomy/astrometry
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 17 Mar 2014; Joseph Jon Booker <joe@neoturbine.net> astrometry-0.43.ebuild:
+ Use python-single-r1 and fix typo for USE=extra
+
14 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
sci-astronomy/astrometry: Added extra use flag to plot
diff --git a/sci-astronomy/astrometry/astrometry-0.43.ebuild b/sci-astronomy/astrometry/astrometry-0.43.ebuild
index 7ba8005d2..4db5cfb1d 100644
--- a/sci-astronomy/astrometry/astrometry-0.43.ebuild
+++ b/sci-astronomy/astrometry/astrometry-0.43.ebuild
@@ -4,7 +4,8 @@
EAPI=5
-inherit eutils toolchain-funcs
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit eutils toolchain-funcs python-single-r1
MYP=${PN}.net-${PV}
@@ -19,12 +20,12 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples extra python"
RDEPEND="
- dev-python/numpy
+ dev-python/numpy[${PYTHON_USEDEP}]
sci-astronomy/wcslib
sci-libs/cfitsio
sci-libs/gsl
sys-libs/zlib
- virtual/pyfits
+ virtual/pyfits[${PYTHON_USEDEP}]
extra? (
media-libs/libpng
media-libs/netpbm
@@ -41,6 +42,13 @@ src_prepare() {
"${FILESDIR}"/0.43-as-needed.patch \
"${FILESDIR}"/0.43-respect-user-flags.patch \
"${FILESDIR}"/0.43-system-libs.patch
+
+ python_fix_shebang "${S}"
+ sed "s|python setup-util.py|${EPYTHON} setup-util.py|" "${S}"/util/Makefile -i
+ sed "s|python setup.py|${EPYTHON} setup.py|" "${S}"/{libkd,sdss,blind}/Makefile -i
+ sed "s|python -c|${EPYTHON} -c|" "${S}"/blind/Makefile -i
+ sed "s|python <<EOF|${EPYTHON} <<EOF|" "${S}"/blind/simplexy.c -i
+ sed "s|python -V|${EPYTHON} -V|" "${S}"/Makefile -i
}
src_compile() {
@@ -56,7 +64,7 @@ src_compile() {
AR=$(tc-getAR) \
extra
fi
- # TODO: work it out for multiple python abi
+
if use python; then
emake \
CC=$(tc-getCC) \
@@ -70,7 +78,7 @@ src_install() {
# TODO: install in standard directories to respect FHS
export INSTALL_DIR="${ED}"/usr/astrometry
emake install-core
- use extra && emake -C blind install-extras
+ use extra && emake -C blind install-extra
# remove cfitsio duplicates
rm ${INSTALL_DIR}/bin/{fitscopy,imcopy,listhead} || die