aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog5
-rw-r--r--sci-astronomy/cpl/cpl-5.0.1.ebuild50
-rw-r--r--sci-astronomy/esorex/ChangeLog8
-rw-r--r--sci-astronomy/esorex/Manifest10
-rw-r--r--sci-astronomy/esorex/esorex-3.6.1.ebuild19
-rw-r--r--sci-astronomy/esorex/esorex-3.6.8.ebuild19
-rw-r--r--sci-astronomy/esorex/esorex-3.7.2.ebuild (renamed from sci-astronomy/esorex/esorex-3.6.12.ebuild)7
7 files changed, 69 insertions, 49 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index 6acabae2a..3a0f5579f 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*cpl-5.0.1 (23 Jul 2009)
+
+ 23 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +cpl-5.0.1.ebuild:
+ Version bump
+
*cpl-4.2.0-r2 (26 Feb 2009)
26 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> -cpl-4.2.0-r1.ebuild,
diff --git a/sci-astronomy/cpl/cpl-5.0.1.ebuild b/sci-astronomy/cpl/cpl-5.0.1.ebuild
new file mode 100644
index 000000000..05c8facac
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-5.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+JAVA_PKG_OPT_USE=gasgano
+inherit java-pkg-opt-2
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/data-processing/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc gasgano"
+
+RDEPEND=">=sci-libs/cfitsio-3.09
+ sci-astronomy/wcslib
+ gasgano? ( >=sci-astronomy/gasgano-2.3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ gasgano? ( >=virtual/jdk-1.5 )"
+
+src_configure() {
+ local myconf="--without-gasgano"
+ use gasgano && \
+ myconf="--with-gasgano=/usr
+ --with-gasgano-classpath=/usr/share/gasgano/lib"
+ econf \
+ --with-cfitsio="/usr" \
+ --with-wcs="/usr" \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS NEWS TODO BUGS ChangeLog
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r html || die
+ fi
+}
diff --git a/sci-astronomy/esorex/ChangeLog b/sci-astronomy/esorex/ChangeLog
index 7d3d00d01..05f219f3c 100644
--- a/sci-astronomy/esorex/ChangeLog
+++ b/sci-astronomy/esorex/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-astronomy/esorex
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*esorex-3.7.2 (23 Jul 2009)
+
+ 23 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> -esorex-3.6.1.ebuild,
+ -esorex-3.6.8.ebuild, -esorex-3.6.12.ebuild, +esorex-3.7.2.ebuild:
+ Version bump
+
08 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
+esorex-3.6.12.ebuild:
Version bump
diff --git a/sci-astronomy/esorex/Manifest b/sci-astronomy/esorex/Manifest
index e050e9a11..c6127d0de 100644
--- a/sci-astronomy/esorex/Manifest
+++ b/sci-astronomy/esorex/Manifest
@@ -1,8 +1,4 @@
-DIST esorex-3.6.1.tar.gz 724825 RMD160 ce94b38c4800e5b88d481db36cac3dbdc6a965d2 SHA1 a07271d4baed4a4b0edd85f7fb172d9a0e234e7d SHA256 cae6b17f7ef9eb66e5898b60bbfcd0fddb1af2d8b79ed0f792bcb3772e7a3216
-DIST esorex-3.6.12.tar.gz 779639 RMD160 fcabe66f478f7497ae483b54b3d2e31fe0b2d45a SHA1 0114cfe3c5217e5abefa23d0ff370e87e617c0e9 SHA256 2b48e89693df1c8072ce2c9dadee885aef442fd3210c9d32c3104b43e9a44714
-DIST esorex-3.6.8.tar.gz 745123 RMD160 7310ba32b5fe0b97b25fbf62cf6a4c9786482ab7 SHA1 309940d6883e5e665f383b1abc068e21d443f652 SHA256 539ce8191af39870712dd36d6492dedaf15452ce5d8cfe402ab327d53fbdf7d0
-EBUILD esorex-3.6.1.ebuild 546 RMD160 68756a5cc917a39d3934189a02e17f129992cb03 SHA1 be98fcb153bee10521527595ba8aabed3fe7b481 SHA256 47a34ea7bd1becfa2e045fce0ae59d26354fcc5c7697d337c000bacbd3409277
-EBUILD esorex-3.6.12.ebuild 588 RMD160 3ef88f8f4957bd11d859b734035a3c50ea938bae SHA1 826d8ae9565c9bd8d9fc92f9d2ab9afa12988cf7 SHA256 6cfbe2163c8c7ffd74595e02bed7ad4e3f67d427564a46fb270b8c3f6b006528
-EBUILD esorex-3.6.8.ebuild 544 RMD160 870628efd8cf6ffb7e8ead9b429c4da0c824d06d SHA1 c0e8eacb7b874f8c0704c00496f863d18cc28ab1 SHA256 cc6ed825a7b31e3dd00544e8d0ef872d29af657ab75f975cc637349c990c840f
-MISC ChangeLog 577 RMD160 661848f6d32d2254217b0d33e04914f7dba1c8f6 SHA1 975325c7c79753030cab7927089021b1456034b0 SHA256 198b524f1bc96e2f0c873c474f8df23ce8ee7b41a552af339fa6e87711483066
+DIST esorex-3.7.2.tar.gz 784544 RMD160 79c13e533577f6e30e8d9f2ae981fde5cb9bc6c3 SHA1 1536099959a3d63f11804fe502fb1b3259d9dc63 SHA256 579de0b9eef9d73238820cce6070d2ed560421ef886b27f4e3c75605e13046c0
+EBUILD esorex-3.7.2.ebuild 630 RMD160 e820697052401fd6fce97aee7922ecdeee3a5220 SHA1 5000847907802f48352fa48115952710595c29fd SHA256 6099aa4c44550c88e5997dd46ee894b7c0022375dc1ed48b785463a26f66aac9
+MISC ChangeLog 768 RMD160 ded75d754b4528f6023faa04b77ce1321c43c4b3 SHA1 3867d41ce1a8d1c415fbff17ad4ae77114bbae2e SHA256 bac8a5376527984dfb8f6985dc0b3a6df4a3f5fe94048c201a37b9c41ddbdfd6
MISC metadata.xml 915 RMD160 6ed5e48cbf1ff25653e71c5fb6e1d81d974ce691 SHA1 dc68a8b74495bd6f1a9e694b6595d037d966b7c4 SHA256 c1287c3d8ea7c525a0d25ac9ab56f5f5be83125b8fb7a5885825a9b251a1deb3
diff --git a/sci-astronomy/esorex/esorex-3.6.1.ebuild b/sci-astronomy/esorex/esorex-3.6.1.ebuild
deleted file mode 100644
index 11468a645..000000000
--- a/sci-astronomy/esorex/esorex-3.6.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
-HOMEPAGE="http://www.eso.org/observing/cpl/esorex"
-SRC_URI="ftp://ftp.hq.eso.org/pub/cpl/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=sci-astronomy/cpl-3.1"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README AUTHORS NEWS TODO BUGS ChangeLog
- insinto /usr/share/doc/${PF}
- doins examples/*
-}
diff --git a/sci-astronomy/esorex/esorex-3.6.8.ebuild b/sci-astronomy/esorex/esorex-3.6.8.ebuild
deleted file mode 100644
index 446f15020..000000000
--- a/sci-astronomy/esorex/esorex-3.6.8.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
-HOMEPAGE="http://www.eso.org/observing/cpl/esorex"
-SRC_URI="ftp://ftp.eso.org/pub/cpl/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=sci-astronomy/cpl-4.1"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README AUTHORS NEWS TODO BUGS ChangeLog
- insinto /usr/share/doc/${PF}
- doins -r examples
-}
diff --git a/sci-astronomy/esorex/esorex-3.6.12.ebuild b/sci-astronomy/esorex/esorex-3.7.2.ebuild
index 1debf7b50..82a429269 100644
--- a/sci-astronomy/esorex/esorex-3.6.12.ebuild
+++ b/sci-astronomy/esorex/esorex-3.7.2.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
-HOMEPAGE="http://www.eso.org/observing/cpl/esorex"
+HOMEPAGE="http://www.eso.org/sci/data-processing/software/cpl/esorex.html"
SRC_URI="ftp://ftp.eso.org/pub/cpl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND=">=sci-astronomy/cpl-4.1"
+DEPEND=">=sci-astronomy/cpl-5"
+RDEPEND="${DEPEND}"
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"