aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/BEP032tools')
-rw-r--r--sci-biology/BEP032tools/BEP032tools-0.0.1_alpha.ebuild44
-rw-r--r--sci-biology/BEP032tools/Manifest1
-rw-r--r--sci-biology/BEP032tools/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-biology/BEP032tools/BEP032tools-0.0.1_alpha.ebuild b/sci-biology/BEP032tools/BEP032tools-0.0.1_alpha.ebuild
new file mode 100644
index 000000000..ec394603d
--- /dev/null
+++ b/sci-biology/BEP032tools/BEP032tools-0.0.1_alpha.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_HASH="a7059ef691e74aeb018edaf37df49c99f6efed60"
+
+DESCRIPTION="Conversion and validation tools for BEP 032"
+HOMEPAGE="https://github.com/INT-NIT/BEP032tools"
+SRC_URI="https://github.com/INT-NIT/BEP032tools/archive/${MY_HASH}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/neo[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/parameterized[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_HASH}"
+
+# Require nixio
+EPYTEST_DESELECT=(
+ "bep032tools/generator/tests/test_BEP032Generator.py::Test_BEP032Data_ece::test_data_file_conversion_0_nix"
+ "bep032tools/generator/tests/test_BEP032Generator.py::Test_BEP032Data_ece::test_data_file_conversion_multi_split"
+ "bep032tools/generator/tests/test_BEP032Generator.py::Test_BEP032Data_ice::test_data_file_conversion_0_nix"
+)
+# Require dynamically fetched data
+EPYTEST_DESELECT+=(
+ "bep032tools/generator/tests/test_nwb2bidsgenerator.py::TestNwbBIDSGenerator::test_nwb_to_bids"
+ "bep032tools/generator/tests/test_nwb2bidsgenerator.py::TestNwbBIDSGenerator::test_validation"
+)
+
+distutils_enable_tests pytest
diff --git a/sci-biology/BEP032tools/Manifest b/sci-biology/BEP032tools/Manifest
new file mode 100644
index 000000000..1e97ed9b1
--- /dev/null
+++ b/sci-biology/BEP032tools/Manifest
@@ -0,0 +1 @@
+DIST BEP032tools-0.0.1_alpha.gh.tar.gz 79175 BLAKE2B dc3d999401d2d4361bfc66b72a39fa02bd6148a377bf63b5bdcc788f4018e486e89743b35ad8f61e232b22f79fed6199dad462aaab60e3bbd1425de117b9c576 SHA512 bf929e5f00cfdd47bbdb9f2240bab97468da5bcb72857e8272eb25857ce7d525b6a97cbc459ace8629d67eb9238b8ddd537e2b6269b73d0173a945b39d5eb59e
diff --git a/sci-biology/BEP032tools/metadata.xml b/sci-biology/BEP032tools/metadata.xml
new file mode 100644
index 000000000..8d24d17e7
--- /dev/null
+++ b/sci-biology/BEP032tools/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">INT-NIT/BEP032tools</remote-id>
+ <remote-id type="pypi">BEP032tools</remote-id>
+ </upstream>
+</pkgmetadata>