aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/Fastaq/Fastaq-3.17.0.ebuild')
-rw-r--r--sci-biology/Fastaq/Fastaq-3.17.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-biology/Fastaq/Fastaq-3.17.0.ebuild b/sci-biology/Fastaq/Fastaq-3.17.0.ebuild
new file mode 100644
index 000000000..443fb3342
--- /dev/null
+++ b/sci-biology/Fastaq/Fastaq-3.17.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulate FASTA/Q, GFF3, EMBL, GBK files with API for developers"
+HOMEPAGE="https://github.com/sanger-pathogens/Fastaq"
+SRC_URI="https://github.com/sanger-pathogens/Fastaq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+# Nominally upstream still uses nose, though it does not encumber us, and tests pass:
+# https://github.com/sanger-pathogens/Fastaq/issues/84