aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/Fastaq/Fastaq-3.17.0.ebuild')
-rw-r--r--sci-biology/Fastaq/Fastaq-3.17.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-biology/Fastaq/Fastaq-3.17.0.ebuild b/sci-biology/Fastaq/Fastaq-3.17.0.ebuild
index 28ff526f6..443fb3342 100644
--- a/sci-biology/Fastaq/Fastaq-3.17.0.ebuild
+++ b/sci-biology/Fastaq/Fastaq-3.17.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -15,4 +16,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-distutils_enable_tests nose
+distutils_enable_tests pytest
+# Nominally upstream still uses nose, though it does not encumber us, and tests pass:
+# https://github.com/sanger-pathogens/Fastaq/issues/84