aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/GAL/GAL-0.2.2_p20200508.ebuild')
-rw-r--r--sci-biology/GAL/GAL-0.2.2_p20200508.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild b/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
index 1aa7e99be..f02907368 100644
--- a/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
+++ b/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit perl-module
@@ -10,16 +10,15 @@ COMMIT="94af39622aab5ba48eb693f2327f6e90f1d202ed"
DESCRIPTION="Genome Annotation Library (incl. fasta_tool)"
HOMEPAGE="https://github.com/The-Sequence-Ontology/GAL"
SRC_URI="https://github.com/The-Sequence-Ontology/GAL/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="( GPL-1+ Artistic )"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
RESTRICT="test"
DEPEND="
- >=dev-lang/perl-5.6.1
- dev-perl/Module-Build
dev-perl/Config-Std
virtual/perl-Data-Dumper
dev-perl/Data-Types
@@ -29,6 +28,7 @@ DEPEND="
dev-perl/Number-Format
virtual/perl-Scalar-List-Utils
dev-perl/Set-IntSpan-Fast
+ dev-perl/Statistics-Descriptive
dev-perl/Statistics-Descriptive-Discrete
dev-perl/Template-Toolkit
dev-perl/Text-Graph
@@ -36,7 +36,12 @@ DEPEND="
dev-perl/Text-Table
dev-perl/Exception-Class
dev-perl/Test-Warn
- dev-perl/URI"
+ dev-perl/URI
+ sci-biology/fasta
+"
RDEPEND="${DEPEND}"
+BDEPEND="dev-perl/Module-Build"
-S="${WORKDIR}/${PN}-${COMMIT}"
+PATCHES=(
+ "${FILESDIR}/Build.PL.patch"
+)