aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/MaSuRCA')
-rw-r--r--sci-biology/MaSuRCA/MaSuRCA-4.0.1.ebuild10
-rw-r--r--sci-biology/MaSuRCA/MaSuRCA-4.1.0.ebuild29
-rw-r--r--sci-biology/MaSuRCA/Manifest1
-rw-r--r--sci-biology/MaSuRCA/metadata.xml3
4 files changed, 39 insertions, 4 deletions
diff --git a/sci-biology/MaSuRCA/MaSuRCA-4.0.1.ebuild b/sci-biology/MaSuRCA/MaSuRCA-4.0.1.ebuild
index 8e6d2925e..7b070e595 100644
--- a/sci-biology/MaSuRCA/MaSuRCA-4.0.1.ebuild
+++ b/sci-biology/MaSuRCA/MaSuRCA-4.0.1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="de Bruijn and OLC assembler for Sanger, Roche 454, Illumina, Pacbio, Nanopore"
HOMEPAGE="http://www.genome.umd.edu/masurca.html
http://bioinformatics.oxfordjournals.org/content/29/21/2669
- https://biorxiv.org/content/biorxiv/early/2016/07/26/066100.full.pdf"
+ https://github.com/alekseyzimin/masurca"
SRC_URI="https://github.com/alekseyzimin/masurca/releases/download/v${PV}/${P}.tar.gz"
LICENSE="BSD GPL-2 GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+# Known to produce build failure:
+# https://github.com/alekseyzimin/masurca/issues/323
+KEYWORDS=""
DEPEND="
>=dev-lang/perl-5.8
diff --git a/sci-biology/MaSuRCA/MaSuRCA-4.1.0.ebuild b/sci-biology/MaSuRCA/MaSuRCA-4.1.0.ebuild
new file mode 100644
index 000000000..7b070e595
--- /dev/null
+++ b/sci-biology/MaSuRCA/MaSuRCA-4.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="de Bruijn and OLC assembler for Sanger, Roche 454, Illumina, Pacbio, Nanopore"
+HOMEPAGE="http://www.genome.umd.edu/masurca.html
+ http://bioinformatics.oxfordjournals.org/content/29/21/2669
+ https://github.com/alekseyzimin/masurca"
+SRC_URI="https://github.com/alekseyzimin/masurca/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+# Known to produce build failure:
+# https://github.com/alekseyzimin/masurca/issues/323
+KEYWORDS=""
+
+DEPEND="
+ >=dev-lang/perl-5.8
+ app-arch/bzip2
+"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ ./install.sh || die
+}
+src_install(){
+ dobin masurca
+}
diff --git a/sci-biology/MaSuRCA/Manifest b/sci-biology/MaSuRCA/Manifest
index 330ac8de3..fd6029f04 100644
--- a/sci-biology/MaSuRCA/Manifest
+++ b/sci-biology/MaSuRCA/Manifest
@@ -1 +1,2 @@
DIST MaSuRCA-4.0.1.tar.gz 26502309 BLAKE2B 658c3a85d3d16bc966f50def9b0f98503f25f89893a18f6b7c361592dc2b20875f4c2b78e55e7279e47d0d381e9f973185da7cf7a1529c617c82b0789dea4183 SHA512 5a52dc6667b501ef5ee33f8c30a516a466b39b061ae3bee93f3e6a9cc9dd21503365671d93858165290b3200c859772324fdb12f8bdab235b3ff08c158c4dd66
+DIST MaSuRCA-4.1.0.tar.gz 26532049 BLAKE2B 93cf8cc2bcb4d2c56961f66c0e045ad7776011b4a5f78e5944c5e9b74004c553fc38e542a163aa2efca0aff0e2726fc38eea1aba8f2da287c5154c9eae4e9bcf SHA512 6de57abff87de2fd8c30bcc7efbd6c37358d37eab518d36ccbe48f036af6e1bc22a655abb59f32df613d99c84a5deca272c8c894395f255bcbceb4da5368e64a
diff --git a/sci-biology/MaSuRCA/metadata.xml b/sci-biology/MaSuRCA/metadata.xml
index 138cb7705..8a631d677 100644
--- a/sci-biology/MaSuRCA/metadata.xml
+++ b/sci-biology/MaSuRCA/metadata.xml
@@ -9,4 +9,7 @@
<email>sci-biology@gentoo.org</email>
<name>Gentoo Biology Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">alekseyzimin/masurca</remote-id>
+ </upstream>
</pkgmetadata>