aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/SPAdes')
-rw-r--r--sci-biology/SPAdes/Manifest8
-rw-r--r--sci-biology/SPAdes/SPAdes-3.15.5.ebuild (renamed from sci-biology/SPAdes/SPAdes-3.15.3.ebuild)10
-rw-r--r--sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch49
-rw-r--r--sci-biology/SPAdes/metadata.xml11
4 files changed, 68 insertions, 10 deletions
diff --git a/sci-biology/SPAdes/Manifest b/sci-biology/SPAdes/Manifest
index 57f4fc569..cf724a82a 100644
--- a/sci-biology/SPAdes/Manifest
+++ b/sci-biology/SPAdes/Manifest
@@ -1,4 +1,4 @@
-DIST SPAdes-3.15.3.tar.gz 13687286 BLAKE2B d1c2204889ecd4e95306f10ca1bc4c1243369737822ba882ed141aa203005ce5240698b421e6f9c867684567abe971afb7562b837ad5464cfd91ce572d5e7af4 SHA512 e1b454c03f1edc857b552ebca9b5f4cd842d8e23caebdf11bb0cd05cb16a45e45421a03c67a5ecb04ea6dba0f30ec2652f0bf07afded39e823563518dc8080f4
-DIST SPAdes-3.15.3_manual.html 80507 BLAKE2B 14510ed5ff2ee1b7a6643f7e39761479180a022c6bae7b1bfac7a07fdf8d5f7889e619fc8bbd6c8354aa7b775241a34b0ab14aa6bf92c0b5af2d0e1588d5c4a7 SHA512 73538e487da7056b42715ec46dacd41e8abef0e268d3a4fe2997b49d208db402367913f3a86acd9643c8ff6a9cadd6d1ff109a2bc511ffb63de059633fe3255b
-DIST SPAdes-3.15.3_rnaspades_manual.html 8624 BLAKE2B b549a6cae6b02c98cae08fd5d8975210f3593c47f2b4757f19a9445a759e332229620885a6fa2f1dc0662096974548e3d0362079d12c47e6738c0261d755a2af SHA512 2d0b169efd8aa7064d59bed8ad406477c72150f23ae0438227903645071c8f66f26fe062f7dd44b584edf8ef7c709ad6c220237e68917ec23c63cfb3139666b8
-DIST SPAdes-3.15.3_truspades_manual.html 10821 BLAKE2B eb466697f774d3421053cf0fd290c82d9b2059cafd787f10c616c1363537c59960cb8ca41a8a02983ec199e0e1a27567c5850009ad6d2173df45e38f7d3120f7 SHA512 1f3bcdbe5397a23ee94820f6aaf3b85c48aca357276f58f66607140d25529c28b31298c5c8e681df3c61dabed478ac67abeb0975885aa9b7e365e14d6aac06fd
+DIST SPAdes-3.15.5.tar.gz 13692466 BLAKE2B c4fe59e6b253c91a6e409cf3c2e5a8181f3c0e93892e3b87f603aa75a6d025d5f1466a87ada5c86d6602f74de9048639e9b057d2abfbe449265f9c1796c608d1 SHA512 98b17f1ab0019a45e6abaf1bc7128a5edb5102120d50a47ddfbd5e30fc7130c7895a096cef16ba8e40be71c8a1f0feff38da54f02f9d2e62bd39d2d91a54f9bd
+DIST SPAdes-3.15.5_manual.html 91156 BLAKE2B e5776ec98e972f52eb630cb2048f8cd12318f0cfc020ce464bbe72e14f3716b72199d5ea34f219351d79b3fd0f4201c99f68ca487edde0d258d8794aea1f4675 SHA512 b21cc705a1f3a224dad882fce26e15dfd6d249c46627172189b285584a11d2846d0fa3c4b5aa01ca6436a494cec552122cffd4b79f6cc31446a03d610486dfaa
+DIST SPAdes-3.15.5_rnaspades_manual.html 8624 BLAKE2B b549a6cae6b02c98cae08fd5d8975210f3593c47f2b4757f19a9445a759e332229620885a6fa2f1dc0662096974548e3d0362079d12c47e6738c0261d755a2af SHA512 2d0b169efd8aa7064d59bed8ad406477c72150f23ae0438227903645071c8f66f26fe062f7dd44b584edf8ef7c709ad6c220237e68917ec23c63cfb3139666b8
+DIST SPAdes-3.15.5_truspades_manual.html 10821 BLAKE2B eb466697f774d3421053cf0fd290c82d9b2059cafd787f10c616c1363537c59960cb8ca41a8a02983ec199e0e1a27567c5850009ad6d2173df45e38f7d3120f7 SHA512 1f3bcdbe5397a23ee94820f6aaf3b85c48aca357276f58f66607140d25529c28b31298c5c8e681df3c61dabed478ac67abeb0975885aa9b7e365e14d6aac06fd
diff --git a/sci-biology/SPAdes/SPAdes-3.15.3.ebuild b/sci-biology/SPAdes/SPAdes-3.15.5.ebuild
index 002004bca..026dd0476 100644
--- a/sci-biology/SPAdes/SPAdes-3.15.3.ebuild
+++ b/sci-biology/SPAdes/SPAdes-3.15.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
DESCRIPTION="De novo de Bruijn genome assembler overcoming uneven coverage"
@@ -27,7 +27,13 @@ DEPEND="
${PYTHON_DEPS}
"
RDEPEND="${DEPEND}"
-BDEPEND="dev-util/cmake"
+BDEPEND="dev-build/cmake"
+
+# Remove for next release:
+# https://github.com/ablab/spades/issues/1238#issuecomment-1904427831
+PATCHES=(
+ "${FILESDIR}/${P}-gcc13.patch"
+)
src_install(){
einstalldocs
diff --git a/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch b/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch
new file mode 100644
index 000000000..3dd3f8c02
--- /dev/null
+++ b/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch
@@ -0,0 +1,49 @@
+From 3e802fa51d156fc958c36e25d607f20bf756f0bf Mon Sep 17 00:00:00 2001
+From: Bo YU <tsu.yubo@gmail.com>
+Date: Wed, 19 Jul 2023 18:42:04 +0800
+Subject: [PATCH] fix build issues due to gcc-13
+
+Signed-off-by: Bo YU <tsu.yubo@gmail.com>
+---
+ ext/include/llvm/Support/Signals.h | 1 +
+ src/common/pipeline/library_data.hpp | 1 +
+ src/common/sequence/nucl.hpp | 2 ++
+ 3 files changed, 4 insertions(+)
+
+diff --git a/assembler/ext/include/llvm/Support/Signals.h b/assembler/ext/include/llvm/Support/Signals.h
+index e0a18e72f..148216b8f 100644
+--- a/ext/include/llvm/Support/Signals.h
++++ b/ext/include/llvm/Support/Signals.h
+@@ -14,6 +14,7 @@
+ #ifndef LLVM_SUPPORT_SIGNALS_H
+ #define LLVM_SUPPORT_SIGNALS_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace llvm {
+diff --git a/assembler/src/common/pipeline/library_data.hpp b/assembler/src/common/pipeline/library_data.hpp
+index 3cbaf0adb..1ffaa7b37 100644
+--- a/src/common/pipeline/library_data.hpp
++++ b/src/common/pipeline/library_data.hpp
+@@ -8,6 +8,7 @@
+
+ #include <map>
+ #include <string>
++#include <cstdint>
+
+ // Forward decls for LLVM YAML API
+ namespace llvm { namespace yaml { class IO; template<typename T> struct MappingTraits; } }
+diff --git a/assembler/src/common/sequence/nucl.hpp b/assembler/src/common/sequence/nucl.hpp
+index 9c7d6de13..e10e7f583 100755
+--- a/src/common/sequence/nucl.hpp
++++ b/src/common/sequence/nucl.hpp
+@@ -8,6 +8,8 @@
+ #ifndef NUCL_HPP_
+ #define NUCL_HPP_
+
++#include <cstdint>
++
+ #include "utils/verify.hpp"
+
+ /**
diff --git a/sci-biology/SPAdes/metadata.xml b/sci-biology/SPAdes/metadata.xml
index 0845ad7a4..5f573393e 100644
--- a/sci-biology/SPAdes/metadata.xml
+++ b/sci-biology/SPAdes/metadata.xml
@@ -10,8 +10,11 @@
<name>Gentoo Biology Project</name>
</maintainer>
<longdescription>
-truSPAdes includes support for Illumina TruSeq Synthetic Long Read technology reads.
-hammer and ionhammer are read error correcting modules for Illumina /IonTorrent reads, resp.
-dipspades is assembly module for highly polymorphic diploid genomes
-</longdescription>
+ truSPAdes includes support for Illumina TruSeq Synthetic Long Read technology reads.
+ hammer and ionhammer are read error correcting modules for Illumina /IonTorrent reads, resp.
+ dipspades is assembly module for highly polymorphic diploid genomes
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ablab/spades</remote-id>
+ </upstream>
</pkgmetadata>