aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/SolexaQA/SolexaQA-3.1.7.1.ebuild')
-rw-r--r--sci-biology/SolexaQA/SolexaQA-3.1.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/SolexaQA/SolexaQA-3.1.7.1.ebuild b/sci-biology/SolexaQA/SolexaQA-3.1.7.1.ebuild
new file mode 100644
index 000000000..81258a0ef
--- /dev/null
+++ b/sci-biology/SolexaQA/SolexaQA-3.1.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Analyze and trim single-end and paired-end reads, show quality statistics"
+HOMEPAGE="https://sourceforge.net/projects/solexaqa"
+SRC_URI="https://sourceforge.net/projects/solexaqa/files/src/SolexaQA++_v${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sys-libs/zlib
+ dev-libs/boost
+"
+BDEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/source"
+
+src_prepare() {
+ default
+ sed -i -e "s/\/lib/$(get_libdir)/g" -e "s/\/include/include\/boost/g" -e 's/-static//' makefile || die
+}
+
+src_install() {
+ newbin SolexaQA++ "${PN}"
+ einstalldocs
+}