aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/abyss')
-rw-r--r--sci-biology/abyss/Manifest1
-rw-r--r--sci-biology/abyss/abyss-2.3.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/abyss/Manifest b/sci-biology/abyss/Manifest
index 12db4dca9..1540aba61 100644
--- a/sci-biology/abyss/Manifest
+++ b/sci-biology/abyss/Manifest
@@ -1,2 +1,3 @@
DIST abyss-2.2.5.tar.gz 1698962 BLAKE2B cb629242dd25b8ca9f9b3f9d7b7f4211a0791b02a4bbbe9c1b11bb436098d1267f37a15ec7409a62e05fd1b75c8ff2f44be20d4a9788e46dfe8b310737e2e32f SHA512 d7ac857f9a9078357c9b7e509379a8b7e0f2e75fc2495f31e30d9403d20b1129372bd51fb601ea2fa37b52cb2dfa158706c121d15ac1746cd958a09c67204ae7
DIST abyss-2.3.0.tar.gz 1530977 BLAKE2B feda6dc6b757a9183157b01c44c6ee7ec721e95860f50a8a44d245932622c91d0f21fd347bfacc50b787f766b18e0f94b69407bbed9c771601825e63f65a8320 SHA512 efd0423dfbf4fa6c8b529a43222cdf9421369093b780b1ce9309a0b7a89ae8ccd77645a4790cbfdacb1d40814bb0aa4f5f3b225a1e0c299b9bc913cb34084a33
+DIST abyss-2.3.1.tar.gz 1531044 BLAKE2B 2365080bdcca3a1fc5af91557da0187af7f18b20d1f91111b6818a8f53991337913d8ff8cf264aaac560bfc0e860e99f6833beb0b78a56ace014c96b869bec8a SHA512 c7fb8b0a1a1346d138a0a64d2a2886b7c081ed628011b614e8ff14d1cbf4a992a8acb1cc668640c0c6a9c22802e4b0cb839f136b8e1f12fe76dae3248cec1777
diff --git a/sci-biology/abyss/abyss-2.3.1.ebuild b/sci-biology/abyss/abyss-2.3.1.ebuild
new file mode 100644
index 000000000..d9134813b
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? (
+ dev-libs/gmp:0=
+ dev-libs/libffi:0=
+ )
+ mpi? ( sys-cluster/openmpi )"
+DEPEND="${RDEPEND}
+ misc-haskell? (
+ dev-lang/ghc
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.5-PathConsensus-assert.patch
+ "${FILESDIR}"/${PN}-2.2.5-ContigProperties.h.patch
+ )
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp) --enable-maxk=256
+}