aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/act-bin/act-bin-13.0.0.ebuild')
-rw-r--r--sci-biology/act-bin/act-bin-13.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-biology/act-bin/act-bin-13.0.0.ebuild b/sci-biology/act-bin/act-bin-13.0.0.ebuild
new file mode 100644
index 000000000..debf770c0
--- /dev/null
+++ b/sci-biology/act-bin/act-bin-13.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit java-pkg-2
+
+DESCRIPTION="DNA contig sequence comparison tool supplementing Artemis"
+HOMEPAGE="http://www.sanger.ac.uk/science/tools/artemis-comparison-tool-act"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/sact_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_manual_complete.pdf -> ${P}.manual.pdf
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_html_build.zip -> ${P}.html_build.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ !sci-biology/artemis"
+RDEPEND="${DEPEND}
+ >=virtual/jre-1.6:*"
+
+S="${WORKDIR}"
+
+src_unpack(){
+ unzip "${DISTDIR}"/${P}.html_build.zip || die
+}
+
+src_prepare(){
+ default
+ cd act_html_build || die
+ rm -f .DS_Store HTML.index HTML.manifest || die
+}
+
+src_install(){
+ java-pkg_dojar "${DISTDIR}"/*.jar
+ dodoc "${DISTDIR}"/${P}.manual.pdf
+ insinto /usr/share/doc/"${PN}"/html
+ doins act_html_build/*
+}
+
+pkg_postinst(){
+ einfo "For BAM file support please install sci-biology/BamView"
+ einfo "You may find interesting the additional web resources:"
+ einfo "http://www.webact.org/WebACT"
+ einfo "http://www.hpa-bioinfotools.org.uk/pise/double_act.html"
+}