aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/behaviopy/behaviopy-0.1.ebuild')
-rw-r--r--sci-biology/behaviopy/behaviopy-0.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/sci-biology/behaviopy/behaviopy-0.1.ebuild b/sci-biology/behaviopy/behaviopy-0.1.ebuild
deleted file mode 100644
index 35bcaab6b..000000000
--- a/sci-biology/behaviopy/behaviopy-0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Neuroimaging tools for Python"
-HOMEPAGE="https://github.com/TheChymera/behaviopy"
-SRC_URI="https://github.com/TheChymera/behaviopy/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="evaluation test"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/seaborn[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-
-src_prepare() {
- if ! use evaluation; then
- rm behaviopy/evaluation.py || die
- fi
- default
-}
-
-python_test() {
- cd behaviopy/examples
- echo "backend : Agg" > matplotlibrc || die
- for i in *py; do
- echo "Executing $i"
- ${EPYTHON} $i || die
- done
-}