aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/behaviopy/behaviopy-0.2.ebuild')
-rw-r--r--sci-biology/behaviopy/behaviopy-0.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sci-biology/behaviopy/behaviopy-0.2.ebuild b/sci-biology/behaviopy/behaviopy-0.2.ebuild
deleted file mode 100644
index dc875e7a5..000000000
--- a/sci-biology/behaviopy/behaviopy-0.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1
-
-DESCRIPTION="Neuroimaging tools for Python"
-HOMEPAGE="https://github.com/TheChymera/behaviopy"
-SRC_URI="https://github.com/TheChymera/behaviopy/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="evaluation"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/seaborn[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- if ! use evaluation; then
- rm behaviopy/evaluation.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd behaviopy/examples || die
- echo "backend : Agg" > matplotlibrc || die
- for i in *py; do
- echo "Executing $i"
- ${EPYTHON} $i || die
- done
-}