aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bowtie/bowtie-2.2.3.ebuild')
-rw-r--r--sci-biology/bowtie/bowtie-2.2.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sci-biology/bowtie/bowtie-2.2.3.ebuild b/sci-biology/bowtie/bowtie-2.2.3.ebuild
deleted file mode 100644
index fb766ec6e..000000000
--- a/sci-biology/bowtie/bowtie-2.2.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Short read aligner supporting gaps, matches to N nucleotides, no end-to-end requirement"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
-SRC_URI="mirror://sourceforge/project/${PN}-bio/${PN}2/${PV}/${PN}2-${PV}-source.zip"
-
-LICENSE="GPL-3"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="examples cpu_flags_x86_sse2"
-REQUIRED_USE="cpu_flags_x86_sse2"
-
-RDEPEND="dev-lang/perl"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-DOCS=( AUTHORS NEWS TUTORIAL )
-HTML_DOCS=( doc/{manual.html,style.css} )
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CFLAGS="" \
- CXXFLAGS="" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS} -msse2"
-}
-
-src_install() {
- dobin ${PN}2 ${PN}2-*
-
- exeinto /usr/libexec/${PN}2
- doexe scripts/*
-
- newman MANUAL ${PN}2.1
- einstalldocs
-
- if use examples; then
- insinto /usr/share/${PN}2
- doins -r example
- fi
-}