aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bx-python/bx-python-0.8.9.ebuild')
-rw-r--r--sci-biology/bx-python/bx-python-0.8.9.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sci-biology/bx-python/bx-python-0.8.9.ebuild b/sci-biology/bx-python/bx-python-0.8.9.ebuild
index a0d3ae3df..6cffba1be 100644
--- a/sci-biology/bx-python/bx-python-0.8.9.ebuild
+++ b/sci-biology/bx-python/bx-python-0.8.9.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..10} )
inherit distutils-r1
DESCRIPTION="Library for rapid implementation of genome scale analyses"
HOMEPAGE="https://github.com/bxlab/bx-python"
-SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
+# (and might need some more work beyond that)
+RESTRICT=test
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
# has file collision with sci-biology/RSeQC
# ToDo: fix doc building:
# Reason: TemplateNotFound('i')
#distutils_enable_sphinx doc/source
+
+distutils_enable_tests pytest