aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bx-python/bx-python-9999.ebuild')
-rw-r--r--sci-biology/bx-python/bx-python-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/sci-biology/bx-python/bx-python-9999.ebuild b/sci-biology/bx-python/bx-python-9999.ebuild
index 6f0b1c9ca..b29975b58 100644
--- a/sci-biology/bx-python/bx-python-9999.ebuild
+++ b/sci-biology/bx-python/bx-python-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..10} )
inherit distutils-r1 git-r3
@@ -14,15 +14,22 @@ EGIT_REPO_URI="https://github.com/bxlab/bx-python"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
+# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
+# (and might need some more work beyond that)
+RESTRICT=test
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
# has file collision with sci-biology/RSeQC
# ToDo: fix doc building:
# Reason: TemplateNotFound('i')
#distutils_enable_sphinx doc/source
+
+distutils_enable_tests pytest