aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bx-python')
-rw-r--r--sci-biology/bx-python/Manifest3
-rw-r--r--sci-biology/bx-python/bx-python-0.8.9.ebuild17
-rw-r--r--sci-biology/bx-python/bx-python-0.9.0.ebuild35
-rw-r--r--sci-biology/bx-python/bx-python-9999.ebuild15
-rw-r--r--sci-biology/bx-python/metadata.xml2
5 files changed, 61 insertions, 11 deletions
diff --git a/sci-biology/bx-python/Manifest b/sci-biology/bx-python/Manifest
index 80552af85..90147dff7 100644
--- a/sci-biology/bx-python/Manifest
+++ b/sci-biology/bx-python/Manifest
@@ -1 +1,2 @@
-DIST bx-python-0.8.9.tar.gz 1651514 BLAKE2B ee75d08aaae8102c2af5be0175c75200382e157abc0c0c723a67b55d5542ab2d4b6ccd4e256975b0a2d00b39b2249d73df0c6f4324b3a74757c3e18e2aeb6c1a SHA512 37863c92258dc06a12b566b02697502f68bbf7e4d9decd8fc63af10ee58b614dd0e7cff35e9977ba1ddf913f176c49e7969728d8e64a9f78ac7100da4a3d70ea
+DIST bx-python-0.8.9.gh.tar.gz 1651514 BLAKE2B ee75d08aaae8102c2af5be0175c75200382e157abc0c0c723a67b55d5542ab2d4b6ccd4e256975b0a2d00b39b2249d73df0c6f4324b3a74757c3e18e2aeb6c1a SHA512 37863c92258dc06a12b566b02697502f68bbf7e4d9decd8fc63af10ee58b614dd0e7cff35e9977ba1ddf913f176c49e7969728d8e64a9f78ac7100da4a3d70ea
+DIST bx-python-0.9.0.gh.tar.gz 1667445 BLAKE2B 0814792a2af8bfb7af5ef5fe1ddc184ed14a68df060a8286f4eba334388497363dc002f6c0de72836b5654452fe28f4cef67cd31b765a4a121c84f3af0634ea0 SHA512 955f396614d8e6d19a74e94a6612f7752a45f752a4a59c95853474dd363ed1960d20a340f17eb1815fda3aaf26d907dc30d37aa8c23608d718742b68864ca1bc
diff --git a/sci-biology/bx-python/bx-python-0.8.9.ebuild b/sci-biology/bx-python/bx-python-0.8.9.ebuild
index a0d3ae3df..6cffba1be 100644
--- a/sci-biology/bx-python/bx-python-0.8.9.ebuild
+++ b/sci-biology/bx-python/bx-python-0.8.9.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..10} )
inherit distutils-r1
DESCRIPTION="Library for rapid implementation of genome scale analyses"
HOMEPAGE="https://github.com/bxlab/bx-python"
-SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
+# (and might need some more work beyond that)
+RESTRICT=test
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
# has file collision with sci-biology/RSeQC
# ToDo: fix doc building:
# Reason: TemplateNotFound('i')
#distutils_enable_sphinx doc/source
+
+distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/bx-python-0.9.0.ebuild b/sci-biology/bx-python/bx-python-0.9.0.ebuild
new file mode 100644
index 000000000..6cffba1be
--- /dev/null
+++ b/sci-biology/bx-python/bx-python-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for rapid implementation of genome scale analyses"
+HOMEPAGE="https://github.com/bxlab/bx-python"
+SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
+# (and might need some more work beyond that)
+RESTRICT=test
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+# has file collision with sci-biology/RSeQC
+
+# ToDo: fix doc building:
+# Reason: TemplateNotFound('i')
+#distutils_enable_sphinx doc/source
+
+distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/bx-python-9999.ebuild b/sci-biology/bx-python/bx-python-9999.ebuild
index 6f0b1c9ca..b29975b58 100644
--- a/sci-biology/bx-python/bx-python-9999.ebuild
+++ b/sci-biology/bx-python/bx-python-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..10} )
inherit distutils-r1 git-r3
@@ -14,15 +14,22 @@ EGIT_REPO_URI="https://github.com/bxlab/bx-python"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
+# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
+# (and might need some more work beyond that)
+RESTRICT=test
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
# has file collision with sci-biology/RSeQC
# ToDo: fix doc building:
# Reason: TemplateNotFound('i')
#distutils_enable_sphinx doc/source
+
+distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/metadata.xml b/sci-biology/bx-python/metadata.xml
index 3e13342e3..f1fc4360e 100644
--- a/sci-biology/bx-python/metadata.xml
+++ b/sci-biology/bx-python/metadata.xml
@@ -10,7 +10,7 @@
<name>Gentoo Biology Project</name>
</maintainer>
<upstream>
- <remote-id type="bitbucket">james_taylor/bx-python</remote-id>
+ <remote-id type="github">bxlab/bx-python</remote-id>
<remote-id type="pypi">bx-python</remote-id>
</upstream>
</pkgmetadata>