aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cutadapt')
-rw-r--r--sci-biology/cutadapt/Manifest2
-rw-r--r--sci-biology/cutadapt/cutadapt-2.10.ebuild42
-rw-r--r--sci-biology/cutadapt/cutadapt-3.3.ebuild42
-rw-r--r--sci-biology/cutadapt/files/cutadapt-3.3-skiptest.patch13
-rw-r--r--sci-biology/cutadapt/metadata.xml20
5 files changed, 0 insertions, 119 deletions
diff --git a/sci-biology/cutadapt/Manifest b/sci-biology/cutadapt/Manifest
deleted file mode 100644
index 30063661a..000000000
--- a/sci-biology/cutadapt/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST cutadapt-2.10.tar.gz 282198 BLAKE2B 87784fd092d3417775f3a627d68bea1d3421f6392ae90f65e9b5f231f10a4da8cfacecc8c6fc3cd8420d0255ffc44ec72188bc901d1768f18f3b78077a165314 SHA512 afefb101a25daa071e5945e442de46cd594a6f4ba5915e9d11943280039223ff5d686b358de44f11b6367f203767d97b76fc529eae70b072139e55831189e594
-DIST cutadapt-3.3.tar.gz 294579 BLAKE2B 1cf833d65a9611e50d747b6ce544dbf639ccc8eab8c5e83425d47bfe5526a0a25faab10cec7b41fad5b012ccf0552948a778b81dac3d5768674326d210dd4540 SHA512 d8895453455aff31c613a4e031559c08646ce2bf072d85ed7b195e5863700a02a1ed44bfb409b63849aadf1db7cf40dea33d0ead4f056307365dc91aa6c93234
diff --git a/sci-biology/cutadapt/cutadapt-2.10.ebuild b/sci-biology/cutadapt/cutadapt-2.10.ebuild
deleted file mode 100644
index c0c263469..000000000
--- a/sci-biology/cutadapt/cutadapt-2.10.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Remove adapter sequences from high-throughput sequencing data"
-HOMEPAGE="https://github.com/marcelm/cutadapt"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- dev-python/dnaio[${PYTHON_USEDEP}]
- dev-python/xopen[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${PYTHON_DEPS}
- ${DEPEND}
-"
-BDEPEND="
- test? (
- dev-python/cython
- dev-python/pytest-mock
- dev-python/pytest-timeout
- dev-python/sphinx
- dev-python/sphinx-issues
- )
-"
-
-distutils_enable_tests pytest
-
-# needs call to installed cutadapt executable
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "pytest failed with ${EPYTHON}"
-}
diff --git a/sci-biology/cutadapt/cutadapt-3.3.ebuild b/sci-biology/cutadapt/cutadapt-3.3.ebuild
deleted file mode 100644
index e1990f222..000000000
--- a/sci-biology/cutadapt/cutadapt-3.3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Remove adapter sequences from high-throughput sequencing data"
-HOMEPAGE="https://github.com/marcelm/cutadapt"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- dev-python/dnaio[${PYTHON_USEDEP}]
- dev-python/xopen[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${PYTHON_DEPS}
- ${DEPEND}
-"
-BDEPEND="
- test? (
- dev-python/cython
- dev-python/pytest-mock
- dev-python/pytest-timeout
- )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-3.3-skiptest.patch )
-
-distutils_enable_tests pytest
-
-# needs call to installed cutadapt executable
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "pytest failed with ${EPYTHON}"
-}
diff --git a/sci-biology/cutadapt/files/cutadapt-3.3-skiptest.patch b/sci-biology/cutadapt/files/cutadapt-3.3-skiptest.patch
deleted file mode 100644
index c2dc2a741..000000000
--- a/sci-biology/cutadapt/files/cutadapt-3.3-skiptest.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/test_command.py b/tests/test_command.py
-index a81b04a..cf40233 100644
---- a/tests/test_command.py
-+++ b/tests/test_command.py
-@@ -76,7 +76,7 @@ def test_force_fasta_output(tmpdir, cores):
- assert_files_equal(cutpath("small.fasta"), out_path)
-
-
--@pytest.mark.skipif(sys.platform == "win32", reason="Maybe this can be made to work")
-+@pytest.mark.skipif(reason="Maybe this can be made to work")
- def test_non_utf8_locale():
- subprocess.check_call(
- [sys.executable, "-m", "cutadapt", "-o", os.devnull, datapath("small.fastq")],
diff --git a/sci-biology/cutadapt/metadata.xml b/sci-biology/cutadapt/metadata.xml
deleted file mode 100644
index 6a2aeb852..000000000
--- a/sci-biology/cutadapt/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mmokrejs@fold.natur.cuni.cz</email>
- <name>Martin Mokrejs</name>
- </maintainer>
- <maintainer type="person">
- <email>gentoo@aisha.cc</email>
- <name>Aisha Tammy</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">marcelm/cutadapt</remote-id>
- <remote-id type="pypi">cutadapt</remote-id>
- </upstream>
-</pkgmetadata>